passive-interface command is used to block RIP broadcasts on an interface connected to a subnet of a RIP-enabled network. In simple words, Passive-interface command is used in all routing protocols to disable sending updates out from a specific interface. A RIP Passive Interface in a nut shell prevents the RIP routing process from sending multicast/broadcast updates out a specified interface. A RIP Passive interface however does not block unicast updates. Keep in mind a Passive Interface DOES NOT block multicast/broadcast updates therefore the router would still process received RIP updates
Tasks:
Configure IP addresses as per diagram
Configure Rip on all networks
Configure R3 Fast Ethernet 0/0 interface to start Rip unicast
Debug by using following commands.
show ip route
show ip route rip
sh ip protocol
debug ip rip events
debug ip rip database

! R1 Configuration

interface Loopback0
ip address 20.1.2.1 255.255.255.255

interface FastEthernet0/0
ip address 1.1.1.10 255.255.255.0
no shut

router rip
version 2
network 1.0.0.0
network 20.0.0.0
no auto-summary


! R2 Configuration

interface Loopback0
ip address 20.1.1.1 255.255.255.255

interface FastEthernet0/0
ip address 1.1.1.20 255.255.255.0
no shut

router rip
version 2
network 1.0.0.0
network 20.0.0.0
no auto-summary


! R3 Configuration

interface Loopback0
ip address 30.1.1.1 255.255.255.255

interface Loopback1
ip address 30.1.2.1 255.255.255.255

interface FastEthernet0/0
ip address 1.1.1.30 255.255.255.0
no shut

router rip
version 2
passive-interface FastEthernet0/0
network 1.0.0.0
network 30.0.0.0
neighbor 1.1.1.20
no auto-summary

Explanation














































Configuring Passive
interface on F0/0 of Router 3
 
Task 1: Use simple authentication between R1 and R2. Key is simplekey
Task 2: Use md5 authentication between R3 and R2. Key is md5key

Debug to verify results

hostname R1


key chain simple
key 1
key-string simplekey

interface Loopback0
ip address 10.1.1.1 255.255.255.255
interface Loopback1
ip address 10.1.1.2 255.255.255.255

interface Serial0/0
no shut
ip address 1.1.1.1 255.255.255.252
ip rip authentication key-chain simple
clock rate 64000

router rip
version 2
network 1.0.0.0
network 10.0.0.0




hostname R2

key chain simple
key 1
key-string simplekey

key chain md5
key 1
key-string md5key

interface Serial0/0
no shut
ip address 1.1.1.2 255.255.255.252
ip rip authentication key-chain simple

interface Serial0/1
no shut
ip address 2.2.2.1 255.255.255.252
ip rip authentication mode md5

ip rip authentication key-chain md5

router rip
version 2
network 1.0.0.0
network 2.0.0.0



hostname R3
key chain md5
key 1
key-string md5key

interface Serial0/0
no shut
ip address 2.2.2.2 255.255.255.252
ip rip authentication mode md5

ip rip authentication key-chain md5
clock rate 64000


router rip
version 2
network 2.0.0.0


Explanation


Key chain name defined
Key chain's key defined
Key's password or string defined forsimple authentication between R1 and R2








Authentication defined on serial interface. Authenticated keychain is "simple"












Keychain defined for simple authentication



Key chain defined for encrypted authentication
i.e. MD5






Key chain named "simple" applied between R1 and R2




Encrypted Authentication applied on interface between R2 and R3
Authentication key chain applied










Encrypted key chain defined named md5.






Encrypted Authentication applied on interface between R2 and R3
Authentication key chain applied
 
Picture
TASKs:
  1. Confiigure IP addresses as per diagram
  2. Configure static ip address on R1 to reach network 2.2.2.0 and Default IP address on R3 to reach network 1.1.1.0

! R1 Configuration
hostname R1

interface FastEthernet0/0
 ip address 1.1.1.1 255.255.255.252
no shut

ip route 2.2.2.0 255.255.255.252 1.1.1.2


! R2 Configuration
hostname R2

interface FastEthernet0/0
 ip address 1.1.1.2 255.255.255.252
no shut

interface FastEthernet0/1
 ip address 2.2.2.1 255.255.255.252
no shut


! R3 Configuration
hostname R3

interface FastEthernet0/0
 ip address 2.2.2.2 255.255.255.252
no shut

ip route 0.0.0.0 0.0.0.0 2.2.2.1



Changing hostname to R1


Assigning ip address to an interface


Configuring static ip address on R1 to reach 2.2.2.0 network via next-hop 1.1.1.2





















Configuring Default ip address on R3 to reach 1.1.1.0 network via 2.2.2.1 Hop
Verification of routes

R1#show ip route

     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/30 is subnetted, 1 subnets
S       2.2.2.0 [1/0] via 1.1.1.2


R2#show ip route

     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/30 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet0/1


R3#show ip route

Gateway of last resort is 2.2.2.1 to network 0.0.0.0

     2.0.0.0/30 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 2.2.2.1

Verification via Ping

R1#ping 2.2.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/90/152 ms


R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/96/232 ms