Frame Relay is a private networking technology similar to the concept of MPLS in that it is delivered in the “cloud”. Frame Relay can run over MPLS to obtain the benefits of traffic prioritization and management. Frame Relay has no quality of service (QoS) manageability and is largely being replaced by the more cost effective MPLS VPN Solutions.


MPLS is a protocol that uses packet labels to prioritize network packets to optimize network performance. If you have Quality of Service (QoS) sensitive applications such as VoIP, video conferencing, SAP, Oracle, Citrix or other real time applications running across your WAN then you should consider MPLS.
Picture
Requirement:
Configure IP address as per topology
CE1 should communicate to all mpls cloud via mpls
FRS1 should communicate to FRS2 and FRS3 via FROMPLS
There should not be any communication between FRS2 and FRS3

! CE1 Configuration

ip cef




mpls ip




mpls label protocol ldp





interface FastEthernet0/0
ip address 200.10.10.100 255.255.255.0
no shut

interface Serial0/0
ip address 11.1.1.1 255.255.255.252
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 11.1.1.0 0.0.0.3 area 0
network 200.10.10.0 0.0.0.255 area 0

ip route 0.0.0.0 0.0.0.0 11.1.1.2


! P1 Configuration

ip cef

mpls label protocol ldp

interface FastEthernet0/0
ip address 160.1.1.1 255.255.255.252
no shut
mpls label protocol ldp
mpls ip

interface Serial0/0
ip address 11.1.1.2 255.255.255.0
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet0/1
ip address 160.1.1.9 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet1/0
ip address 160.1.1.13 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 11.1.1.0 0.0.0.3 area 0
network 160.1.1.0 0.0.0.3 area 0
network 160.1.1.8 0.0.0.3 area 0
network 160.1.1.12 0.0.0.3 area 0


! P3 Configuration

ip cef

mpls label protocol ldp

interface FastEthernet0/0
ip address 160.1.1.17 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet0/1
ip address 160.1.1.14 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet1/0
ip address 160.1.1.25 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 160.1.1.12 0.0.0.3 area 0
network 160.1.1.16 0.0.0.3 area 0
network 160.1.1.24 0.0.0.3 area 0


! PE2 Configuration

ip cef

frame-relay switching

mpls label protocol ldp

interface Loopback0
ip address 15.15.15.15 255.255.255.255


interface FastEthernet0/0
ip address 160.1.1.21 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
no shut

interface FastEthernet0/1
ip address 160.1.1.26 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 15.15.15.15 0.0.0.0 area 0
network 160.1.1.20 0.0.0.3 area 0
network 160.1.1.24 0.0.0.3 area 0

connect FRS3-FRS1 Serial0/0 301 l2transport







xconnect 13.13.13.13 20 encapsulation mpls













mpls ldp router-id Loopback0 force




! P2 Configuration

ip cef

frame-relay switching

mpls label protocol ldp

interface Loopback0
ip address 14.14.14.14 255.255.255.255

interface FastEthernet0/0
ip address 160.1.1.10 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface Serial0/0
no ip address
encapsulation frame-relay
frame-relay intf-type dce
no shut

interface FastEthernet0/1
ip address 160.1.1.5 255.255.255.252
duplex auto
speed auto
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet1/0
ip address 160.1.1.18 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

interface FastEthernet2/0
ip address 160.1.1.22 255.255.255.252
speed 100
full-duplex
mpls label protocol ldp
mpls ip
no shut

router ospf 10
network 14.14.14.14 0.0.0.0 area 0
network 160.1.1.4 0.0.0.3 area 0
network 160.1.1.8 0.0.0.3 area 0
network 160.1.1.16 0.0.0.3 area 0
network 160.1.1.20 0.0.0.3 area 0

connect FR2-FRS1 Serial0/0 201 l2transport xconnect 13.13.13.13 10 encapsulation mpls

mpls ldp router-id Loopback0 force


! PE1 Configuration


ip cef

frame-relay switching

mpls label protocol ldp

interface Loopback0
ip address 13.13.13.13 255.255.255.255

interface FastEthernet0/0
ip address 160.1.1.2 255.255.255.252
no shut
mpls label protocol ldp
mpls ip

interface Serial0/0
no ip address
encapsulation frame-relay
no shut
frame-relay intf-type dce

interface FastEthernet0/1
ip address 160.1.1.6 255.255.255.252
no shut
mpls label protocol ldp
mpls ip

router ospf 10
network 13.13.13.13 0.0.0.0 area 0
network 160.1.1.0 0.0.0.3 area 0
network 160.1.1.4 0.0.0.3 area 0

connect FRS1-FRS2 Serial0/0 102 l2transport
xconnect 14.14.14.14 10 encapsulation mpls

connect FRS1-FRS3 Serial0/0 103 l2transport

xconnect 15.15.15.15 20 encapsulation mpls
mpls ldp router-id Loopback0 force


! FRS1 Configuration

interface Serial0/0
ip address 12.12.12.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 102
frame-relay interface-dlci 103
no shut

ip route 0.0.0.0 0.0.0.0 Serial0/0

!FRS2 Configuration

interface Serial0/0
ip address 19.19.19.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 201
no shut

ip route 0.0.0.0 0.0.0.0 Serial0/0


!FRS3 Configuration

interface Serial0/0
ip address 21.1.1.1 255.255.255.252
encapsulation frame-relay
frame-relay interface-dlci 301
no shut

ip route 0.0.0.0 0.0.0.0 Serial0/0
Configuration Explanation

Cisco's Express Forwarding (CEF) is an Layer 3 fastest switching technology by which Cisco router forwards packets from ingress to egress interfaces.
Note: This is a essential command

Globally enabling MPLS forwarding does not enable it on the router interfaces. You must enable MPLS forwarding on the interfaces as well as for the router.

Enable LDP protocol globally. MPLS Label Distribution Protocol (LDP) enables peer label switch routers (LSRs) in an MPLS network to exchange label binding information for supporting hop-by-hop forwarding in an MPLS network


Enabling interface with IP address



Enabling interface with IP address

Enabling MPLS LDP on interface
Enable Mpls IP on interface


Configuring OSPF for two networks



Default route



















































































command will enable your router to act as frame relay switch


Loopback interface ip. We are using this to enable our FR over MPLS communication through connect and xconnect commands given below




























In previous releases of AToM, the command used to configure AToM circuits was mpls l2 transport route. This command has been replaced with the xconnect command.

Applied command is telling to connect DLCI 301 and transport it via serial 0/0

The xconnect command is not supported on Frame Relay interfaces directly. For Frame Relay, the Xconnect is applied under the connectcommand specifying the DLCI to be used. we would directly apply xconnect directly to the customer interface, i.e under an ethernet interface or when the encapsulation is PPP or HDLC on a serial link. Frame relay encapsulation requires an alternate configuration.

command is telling to connect to router-id 13.13.13.13 having virtual circuit 20 using encapsulation type mpls

Enforcing MPLS router ID to be loopback 0 ip address. This will break LDP neighbor relationship and reestablish it


 
Picture
Requirement:
  • Configure ip addresses as per topology
  • Configure one loopback address on each router i.e. 10.10.10.10 on R1 ; 20.20.20.20 on R2 ; 30.30.30.30 on R3 ; 40.40.40.40 on R4 and 50.50.50.50 on R5
  • Configure ospf on specified networks
  • Configure ibgp and ebgp as per topology
  • Configure MPLS on core network
  • Verify connectivity annd communication via mpls

    Verification commands:
  • traceroute ip 50.50.50.50 source 40.40.40.40
  • traceroute mpls ipv4 50.50.50.50/32 (very imp)
  • ping mpls ipv4 30.30.30.30/32
  • sh ip route :: Show ip bgp :: clear ip bgp *
  • show mpls ldp neigehbor
  • show mpls forwarding
  • show mpls ldp binding

! R1 configuration

hostname R1
ip cef
mpls label protocol ldp

interface Loopback0
 ip address 10.10.10.10 255.255.255.0

interface Serial0/0
 ip address 1.1.1.1 255.255.255.0
 mpls ip
no shut

interface Serial0/1
 ip address 9.9.9.1 255.255.255.252
no shut

router ospf 10
 redistribute bgp 10 subnets
 network 1.1.1.0 0.0.0.255 area 0
 network 10.10.10.10 0.0.0.0 area 0

router bgp 10
 neighbor 9.9.9.2 remote-as 100
 neighbor 9.9.9.2 distribute-list 1 out
 neighbor 30.30.30.30 remote-as 10
 neighbor 30.30.30.30 update-source Loopback0
 neighbor 30.30.30.30 next-hop-self
 no auto-summary

access-list 1 deny   50.50.50.50
access-list 1 permit any


! R2 Configuration

hostname R2
ip cef
mpls label protocol ldp

interface Loopback0
 ip address 20.20.20.20 255.255.255.255

interface Serial0/0
 ip address 1.1.1.2 255.255.255.0
 mpls ip
no shut

interface Serial0/1
 ip address 1.1.10.1 255.255.255.0
 mpls ip
no shut

router ospf 10
 network 1.1.1.0 0.0.0.255 area 0
 network 1.1.10.0 0.0.0.255 area 0
 network 20.20.20.20 0.0.0.0 area 0
! R3 Configuration

hostname R3
ip cef
mpls label protocol ldp

interface Loopback0
 ip address 30.30.30.30 255.255.255.255

interface Serial0/0
 ip address 1.1.10.11 255.255.255.0
 mpls ip
no shut

interface Serial0/1
 ip address 6.6.6.1 255.255.255.252
no shut

router ospf 10
 redistribute bgp 10 subnets
 network 1.1.10.0 0.0.0.255 area 0
 network 30.30.30.30 0.0.0.0 area 0

router bgp 10
 neighbor 6.6.6.2 remote-as 200
 neighbor 6.6.6.2 distribute-list 1 out
 neighbor 10.10.10.10 remote-as 10
 neighbor 10.10.10.10 update-source Loopback0
 neighbor 10.10.10.10 next-hop-self
 no auto-summary

access-list 1 deny   40.40.40.40
access-list 1 permit any


! R4 Configuration

hostname R4

interface Loopback0
 ip address 40.40.40.40 255.255.255.255

interface Serial0/0
 ip address 9.9.9.2 255.255.255.252
no shut

router bgp 100
 network 40.40.40.40 mask 255.255.255.255
 neighbor 9.9.9.1 remote-as 10
 no auto-summary

ip route 0.0.0.0 0.0.0.0 9.9.9.1


! R5 Configuration

hostname R5

interface Loopback0
 ip address 50.50.50.50 255.255.255.255

interface Serial0/0
 ip address 6.6.6.2 255.255.255.252
no shut

router bgp 200
 network 50.50.50.50 mask 255.255.255.255
 neighbor 6.6.6.1 remote-as 10
 no auto-summary

ip route 0.0.0.0 0.0.0.0 6.6.6.1

Verification:

R4#traceroute ip 50.50.50.50 source 40.40.40.40

Type escape sequence to abort.
Tracing the route to 50.50.50.50

  1 9.9.9.1 56 msec 4 msec 8 msec
  2 1.1.1.2 [MPLS: Label 16 Exp 0] 72 msec 16 msec 0 msec
  3 1.1.10.11 60 msec 44 msec 20 msec
  4 6.6.6.2 64 msec *  132 msec


R1#show mpls forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     1.1.10.0/24       0          Se0/0      point2point
17     16          50.50.50.50/32    0          Se0/0      point2point
18     Pop tag     20.20.20.20/32    0          Se0/0      point2point
19     19          30.30.30.30/32    0          Se0/0      point2point
R1#


R2#show mpls ldp neighbor
    Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 20.20.20.20:0
        TCP connection: 10.10.10.10.646 - 20.20.20.20.53911
        State: Oper; Msgs sent/rcvd: 151/151; Downstream
        Up time: 02:00:22
        LDP discovery sources:
          Serial0/0, Src IP addr: 1.1.1.1
        Addresses bound to peer LDP Ident:
          1.1.1.1         9.9.9.1         10.10.10.10

    Peer LDP Ident: 30.30.30.30:0; Local LDP Ident 20.20.20.20:0
        TCP connection: 30.30.30.30.37364 - 20.20.20.20.646
        State: Oper; Msgs sent/rcvd: 145/147; Downstream
        Up time: 01:59:44
        LDP discovery sources:
          Serial0/1, Src IP addr: 1.1.10.11
        Addresses bound to peer LDP Ident:
          1.1.10.11       6.6.6.1         30.30.30.30


 
In this scenerio; we are trying to communicate two customers via MPLS SP cloud.

A CE router ( customer edge router ) is a router located on the customer premises that provides an Ethernet interface between the customer's LAN and the provider's core network. CE routers, P (provider) routers and PE (provider edge) routers are components in an MPLS (multiprotocol label switching) architecture. Provider routers are located in the core of the provider or carrier's network. Provider edge routers sit at the edge of the network. CE routers connect to PE routers and PE routers connect to other PE routers over P routers.

Picture
Requirement:
  • Configure IP address as per toplogy
  • Configure 2.2.2.2 as PE2 router ID, 3.3.3.3 P2 router ID, 4.4.4.4 P1 router ID and 1.1.1.1 as PE1 router ID.
  • Configure EIGRP as a routing protocol
  • Configure MPLS with-in cloud.
  • Verify communication via MPLS

Verificaton Command
  •  show mpls ip binding
  • show ip cef
  • show mpls interfaces
  • show mpls ldp discovery
  • show mpls ldp nei
  • show mpls forwarding-table


! CE1 Configuration
ip cef





interface FastEthernet1/0
ip address 200.1.2.1 255.255.255.0
no shut

router eigrp 10
network 200.1.2.0
no auto-summary

! CE2 Configuration
ip cef

interface Loopback0
ip address 10.1.1.1 255.255.255.0

interface FastEthernet1/0
ip address 200.1.1.1 255.255.255.0
no shut

router eigrp 10
network 10.0.0.0
network 200.1.1.0
no auto-summary


! PE1 Configuration

ip cef

mpls label protocol ldp





interface Loopback0
ip address 1.1.1.1 255.255.255.255

interface FastEthernet1/0
ip address 200.1.2.2 255.255.255.0
no shut

interface Serial2/0
ip address 200.1.7.1 255.255.255.0
mpls label protocol ldp

mpls ip



no shut

interface Serial2/1
ip address 200.1.6.1 255.255.255.0
mpls label protocol ldp
mpls ip
no shut

router eigrp 10
network 1.0.0.0
network 200.1.2.0
network 200.1.6.0
network 200.1.7.0
no auto-summary


! PE2 Configuration

ip cef

mpls label protocol ldp

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface FastEthernet1/0
 ip address 200.1.1.2 255.255.255.0
  no shut

interface Serial2/0
 ip address 200.1.4.1 255.255.255.0
 mpls label protocol ldp
 mpls ip
no shut
!
interface Serial2/1
 ip address 200.1.3.1 255.255.255.0
 mpls label protocol ldp
 mpls ip
 no shut

router eigrp 10
 network 2.0.0.0
 network 200.1.1.0
 network 200.1.3.0
 network 200.1.4.0
 no auto-summary

! P1 Configuration
ip cef

mpls label protocol ldp

interface Loopback0
 ip address 4.4.4.4 255.255.255.255

interface Serial1/0
 ip address 200.1.7.2 255.255.255.0
 mpls label protocol ldp
 mpls ip
no shut
!
interface Serial1/1
 ip address 200.1.4.2 255.255.255.0
 mpls label protocol ldp
 mpls ip
no shut
!
interface Serial1/2
 ip address 200.1.5.2 255.255.255.0
 mpls label protocol ldp
 mpls ip
no shut

router eigrp 10
 network 4.0.0.0
 network 200.1.4.0
 network 200.1.5.0
 network 200.1.7.0
 no auto-summary

!P2 Configuration
ip cef

mpls label protocol ldp

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial1/0
 ip address 200.1.6.2 255.255.255.0
 mpls label protocol ldp
 mpls ip
no shut
!
interface Serial1/1
 ip address 200.1.3.2 255.255.255.0
 mpls label protocol ldp
 mpls ip
no shut
!
interface Serial1/2
 ip address 200.1.5.1 255.255.255.0
 mpls label protocol ldp
 mpls ip
no shut

router eigrp 10
 network 3.0.0.0
 network 200.1.3.0
 network 200.1.5.0
 network 200.1.6.0
 no auto-summary


Configuration Explanation
Cisco's Express Forwarding (CEF) is an Layer 3 fastest switching technology by which Cisco router forwards packets from ingress to egress interfaces.
Note: This is a essential command











For explanation; See above

Enabling IP address to loopback interface






Enabling EIGRP autonomous no 10







See above for command explanation

Enable LDP protocol globally. MPLS Label Distribution Protocol (LDP) enables peer label switch routers (LSRs) in an MPLS network to exchange label binding information for supporting hop-by-hop forwarding in an MPLS network












Globally enabling MPLS forwarding does not enable it on the router interfaces. You must enable MPLS forwarding on the interfaces as well as for the router.

CE1#traceroute 10.1.1.1                            ====> Look at the output; MPLs is working

Type escape sequence to abort.
Tracing the route to 10.1.1.1

  1 200.1.2.2 80 msec 44 msec 32 msec
  2 200.1.7.2 [MPLS: Label 23 Exp 0] 80 msec 64 msec 60 msec
  3 200.1.4.1 [MPLS: Label 23 Exp 0] 172 msec 60 msec 76 msec
  4 200.1.1.1 92 msec *  176 msec

check all verification commands by yourself.