Picture
Requirement:
  • Configure ip addresses as per topology
  • Configure one loopback address on each router i.e. 10.10.10.10 on R1 ; 20.20.20.20 on R2 ; 30.30.30.30 on R3 ; 40.40.40.40 on R4 and 50.50.50.50 on R5
  • Configure ospf on specified networks
  • Configure ibgp and ebgp as per topology
  • Configure MPLS on core network
  • Verify connectivity annd communication via mpls

    Verification commands:
  • traceroute ip 50.50.50.50 source 40.40.40.40
  • traceroute mpls ipv4 50.50.50.50/32 (very imp)
  • ping mpls ipv4 30.30.30.30/32
  • sh ip route :: Show ip bgp :: clear ip bgp *
  • show mpls ldp neigehbor
  • show mpls forwarding
  • show mpls ldp binding

! R1 configuration

hostname R1
ip cef
mpls label protocol ldp

interface Loopback0
 ip address 10.10.10.10 255.255.255.0

interface Serial0/0
 ip address 1.1.1.1 255.255.255.0
 mpls ip
no shut

interface Serial0/1
 ip address 9.9.9.1 255.255.255.252
no shut

router ospf 10
 redistribute bgp 10 subnets
 network 1.1.1.0 0.0.0.255 area 0
 network 10.10.10.10 0.0.0.0 area 0

router bgp 10
 neighbor 9.9.9.2 remote-as 100
 neighbor 9.9.9.2 distribute-list 1 out
 neighbor 30.30.30.30 remote-as 10
 neighbor 30.30.30.30 update-source Loopback0
 neighbor 30.30.30.30 next-hop-self
 no auto-summary

access-list 1 deny   50.50.50.50
access-list 1 permit any


! R2 Configuration

hostname R2
ip cef
mpls label protocol ldp

interface Loopback0
 ip address 20.20.20.20 255.255.255.255

interface Serial0/0
 ip address 1.1.1.2 255.255.255.0
 mpls ip
no shut

interface Serial0/1
 ip address 1.1.10.1 255.255.255.0
 mpls ip
no shut

router ospf 10
 network 1.1.1.0 0.0.0.255 area 0
 network 1.1.10.0 0.0.0.255 area 0
 network 20.20.20.20 0.0.0.0 area 0
! R3 Configuration

hostname R3
ip cef
mpls label protocol ldp

interface Loopback0
 ip address 30.30.30.30 255.255.255.255

interface Serial0/0
 ip address 1.1.10.11 255.255.255.0
 mpls ip
no shut

interface Serial0/1
 ip address 6.6.6.1 255.255.255.252
no shut

router ospf 10
 redistribute bgp 10 subnets
 network 1.1.10.0 0.0.0.255 area 0
 network 30.30.30.30 0.0.0.0 area 0

router bgp 10
 neighbor 6.6.6.2 remote-as 200
 neighbor 6.6.6.2 distribute-list 1 out
 neighbor 10.10.10.10 remote-as 10
 neighbor 10.10.10.10 update-source Loopback0
 neighbor 10.10.10.10 next-hop-self
 no auto-summary

access-list 1 deny   40.40.40.40
access-list 1 permit any


! R4 Configuration

hostname R4

interface Loopback0
 ip address 40.40.40.40 255.255.255.255

interface Serial0/0
 ip address 9.9.9.2 255.255.255.252
no shut

router bgp 100
 network 40.40.40.40 mask 255.255.255.255
 neighbor 9.9.9.1 remote-as 10
 no auto-summary

ip route 0.0.0.0 0.0.0.0 9.9.9.1


! R5 Configuration

hostname R5

interface Loopback0
 ip address 50.50.50.50 255.255.255.255

interface Serial0/0
 ip address 6.6.6.2 255.255.255.252
no shut

router bgp 200
 network 50.50.50.50 mask 255.255.255.255
 neighbor 6.6.6.1 remote-as 10
 no auto-summary

ip route 0.0.0.0 0.0.0.0 6.6.6.1

Verification:

R4#traceroute ip 50.50.50.50 source 40.40.40.40

Type escape sequence to abort.
Tracing the route to 50.50.50.50

  1 9.9.9.1 56 msec 4 msec 8 msec
  2 1.1.1.2 [MPLS: Label 16 Exp 0] 72 msec 16 msec 0 msec
  3 1.1.10.11 60 msec 44 msec 20 msec
  4 6.6.6.2 64 msec *  132 msec


R1#show mpls forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     1.1.10.0/24       0          Se0/0      point2point
17     16          50.50.50.50/32    0          Se0/0      point2point
18     Pop tag     20.20.20.20/32    0          Se0/0      point2point
19     19          30.30.30.30/32    0          Se0/0      point2point
R1#


R2#show mpls ldp neighbor
    Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 20.20.20.20:0
        TCP connection: 10.10.10.10.646 - 20.20.20.20.53911
        State: Oper; Msgs sent/rcvd: 151/151; Downstream
        Up time: 02:00:22
        LDP discovery sources:
          Serial0/0, Src IP addr: 1.1.1.1
        Addresses bound to peer LDP Ident:
          1.1.1.1         9.9.9.1         10.10.10.10

    Peer LDP Ident: 30.30.30.30:0; Local LDP Ident 20.20.20.20:0
        TCP connection: 30.30.30.30.37364 - 20.20.20.20.646
        State: Oper; Msgs sent/rcvd: 145/147; Downstream
        Up time: 01:59:44
        LDP discovery sources:
          Serial0/1, Src IP addr: 1.1.10.11
        Addresses bound to peer LDP Ident:
          1.1.10.11       6.6.6.1         30.30.30.30


 
This lab is same as previous Lab " HSRP Redundancy in Multi-homed ISPs - BGP AS-Path prepending" in many aspects but there were some short commings left in previous labs. Previously if our immediate route failed between our HSRP divice and ISP; we can track that but what if; Any of the link between source and destination fail. Previous configuration let our HSRP device working as Active device and we will face severe packet losses and communication errors. Here in this lab we will track ip addresses instead of connected interfaces so that if that route become unavailable then Active HSRP shift its role to standby ISP.

Let's do our lab.
Picture
Requiremnents:
  • Configure IP Addresses as per diagram. Configure one loop back address 5.5.5.5 on Internet router.
  • Configure HSRP on both HSRP1 (Active) and HSRP2 (standby). Track ip address between HSRP1 & internet for fail-over.
  • Configure IBGP in a way that HSRP1 should not sent BGP update to its neighbor HSRP2 and vice versa
  • Without doing any configuration related to propagating any network to neighbors, redistribution, static routing. Make sure network 100.10.10.0 should communicate to network 5.5.5.5.
  • Packet coming from internet router to LAN should take preffered path and ensure that secondary path route becomes less preferred as compared to preferred path
  • For verification use following command and compare results with previous Lab " HSRP Redundancy in Multi-homed ISPs - BGP AS-Path prepending" results. Follow these commands and take help from previous lab
  • Show ip route ; Show ip bgp ip-address ; traceroute or tracert ; ping ; show standby (for HSRP) ; show standby brief ; show ip bgp summary ; show ip bgp ; debug ip bgp etc

! HSRP1 Configuration
interface Serial0/0
ip address 16.16.16.1 255.255.255.0
no shut

interface FastEthernet0/1
ip address 100.10.10.1 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 150
standby 10 preempt delay minimum 70

standby 10 track 1 decrement 60




track 1 ip route 5.5.5.0 255.255.255.0 reachability



router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 16.16.16.2 remote-as 80
neighbor 100.10.10.2 remote-as 50
neighbor 100.10.10.2 next-hop-self
neighbor 100.10.10.2 transport connection-mode passive



! HSRP2 Configuration
interface FastEthernet0/0
ip address 100.10.10.2 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 120
standby 10 preempt
standby 10 track Serial0/0

interface Serial0/0
ip address 22.22.22.1 255.255.255.0
no shut

router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 22.22.22.2 remote-as 200
neighbor 22.22.22.2 route-map AS-Path-Append out

neighbor 100.10.10.1 remote-as 50
neighbor 100.10.10.1 next-hop-self
neighbor 100.10.10.1 transport connection-mode passive

access-list 10 permit 100.10.10.0


route-map AS-Path-Append permit 10
match ip address 10
set as-path prepend 50




! ISP1 Configuration
interface Serial0/0
ip address 16.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 160.16.16.1 255.255.255.0
no shut

router bgp 80
neighbor 16.16.16.1 remote-as 50
neighbor 160.16.16.2 remote-as 500

! ISP2 Configuration
interface Serial0/0
ip address 22.22.22.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.2 255.255.255.0
no shut

router bgp 200
neighbor 22.22.22.1 remote-as 50
neighbor 210.16.16.1 remote-as 500

! Internet Configuration
interface Loopback0
ip address 5.5.5.5 255.255.255.0

interface Serial0/0
ip address 160.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.1 255.255.255.0
no shut

router bgp 500
network 5.5.5.0 mask 255.255.255.0
neighbor 160.16.16.1 remote-as 80
neighbor 210.16.16.2 remote-as 200
Configuration Explanation










70 seconds delay so that BGP routes get into routing table.
Tracking track 1 (mentioned in next command). If 5.5.5.0 route fail to come into route table of HSRP1 ; HSRP1 shift role to standby router (HSRP router) by decrementing its current priority from 150 to 90

track to check if 5.5.5.0 is reachable









This command let HSRP2 not sending updates to its specified neighbor






















when communicating to neighbor 22.22.22.2 and sending information out to it; BGP should consult route-map name AS-PAth-Append

This command let HSRP2 not sending updates to its specified neighbor


Access list 10 permitting route. (We use this in route map)

Here comes route map
route map will match all ip addresses in access list 10
if match found then it will prepend its AS-Path attribute with 50. This will let outside world (AS) perceive that this route is the longest one as compared some other actually equal route.
 
In this lab, we are going to use IBGP and EBGP for peer relationship. HSRP will provide us redundant gateways as if active fail; standby will take the place of active HSRP. Read requirements carefully.
Picture
Requiremnents:
  • Configure IP Addresses as per diagram. Configure one loop back address 5.5.5.5 on Internet router.
  • Configure HSRP on both HSRP1 (Active) and HSRP2 (standby). Track interface between HSRP1 & ISP1 and HSRP2 & ISP2 for fail-over.
  • Without doing any configuration related to propagating any network to neighbors, redistribution, static routing. Make sure network 100.10.10.0 should communicate to network 5.5.5.5.
  • Packet coming from internet router to LAN should take preffered path and ensure that secondary path route becomes less preferred as compared to preferred path
  • Demonstrate internet router path for 100.10.10.0 network by using show ip bgp 100.10.10.0 command and by traceroute.

! HSRP1 Configuration
interface Serial0/0
ip address 16.16.16.1 255.255.255.0
no shut

interface FastEthernet0/1
ip address 100.10.10.1 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 150
standby 10 preempt delay minimum 70

standby 10 track Serial0/0 60

router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 16.16.16.2 remote-as 80
neighbor 100.10.10.2 remote-as 50
neighbor 100.10.10.2 next-hop-self

! HSRP2 Configuration
interface FastEthernet0/0
ip address 100.10.10.2 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 120
standby 10 preempt
standby 10 track Serial0/0

interface Serial0/0
ip address 22.22.22.1 255.255.255.0
no shut

router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 22.22.22.2 remote-as 200
neighbor 22.22.22.2 route-map AS-Path-Append out

neighbor 100.10.10.1 remote-as 50
neighbor 100.10.10.1 next-hop-self

access-list 10 permit 100.10.10.0


route-map AS-Path-Append permit 10
match ip address 10
set as-path prepend 50




! ISP1 Configuration
interface Serial0/0
ip address 16.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 160.16.16.1 255.255.255.0
no shut

router bgp 80
neighbor 16.16.16.1 remote-as 50
neighbor 160.16.16.2 remote-as 500

! ISP2 Configuration
interface Serial0/0
ip address 22.22.22.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.2 255.255.255.0
no shut

router bgp 200
neighbor 22.22.22.1 remote-as 50
neighbor 210.16.16.1 remote-as 500

! Internet Configuration
interface Loopback0
ip address 5.5.5.5 255.255.255.0

interface Serial0/0
ip address 160.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.1 255.255.255.0
no shut

router bgp 500
network 5.5.5.0 mask 255.255.255.0
neighbor 160.16.16.1 remote-as 80
neighbor 210.16.16.2 remote-as 200
Configuration Explanation










70 seconds delay so that BGP routes get into routing table.
Tracking serial 0/0 so that if it gets failed; HSRP shift role to standby router























when communicating to neighbor 22.22.22.2 and sending information out to it; BGP should consult route-map name AS-PAth-Append



Access list 10 permitting route. (We use this in route map)

Here comes route map
route map will match all ip addresses in access list 10
if match found then it will prepend its AS-Path attribute with 50. This will let outside world (AS) perceive that this route is the longest one as compared some other actually equal route.

BGP network verification

Internet#show ip bgp 100.10.10.0
BGP routing table entry for 100.10.10.0/24, version 3
Paths: (2 available, best #2, table Default-IP-Routing-Table)
Flag: 0x820
  Advertised to update-groups:
        1
  200 50 50 [Look here you see that actual AS-Path should have (200 50) but due to route map and AS-Path prepend applied on HSRP2 router; Router AS path is showing that this route will go from 3 AS]
    210.16.16.2 from 210.16.16.2 (210.16.16.2)
      Origin IGP, localpref 100, valid, external
  80 50 [Here there are 2 AS in AS-Path; hence preferable]
    160.16.16.1 from 160.16.16.1 (160.16.16.1)
      Origin IGP, localpref 100, valid, external, best

Trace route verification

When both HSRP routers are running cool and tracked interfaces have no issues at all. Following is the trace route.

pc1V10[1]> tracert 5.5.5.5
traceroute to 5.5.5.5, 64 hops max, press Ctrl+C to stop
 1   100.10.10.1   70.000 ms  62.000 ms  40.000 ms
 2   16.16.16.2   80.000 ms  40.000 ms  36.000 ms
 3   *160.16.16.2   107.000 ms

(Please note that as 5.5.5.5 is a loopback thats why
traceroute just stops here)

Anyhow see the path. PAckets are taking HSRP1 path.

Now I have shutdown HSRP and ISP1 interface so that HSRP2 should take Active role. Now see results

Internet#show ip bgp 100.10.10.0
BGP routing table entry for 100.10.10.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Advertised to update-groups:
        1
  200 50 50
    210.16.16.2 from 210.16.16.2 (210.16.16.2)
      Origin IGP, localpref 100, valid, external, best

Please note that now previously preferred route is not there
pc1V10[1]> tracert 5.5.5.5
traceroute to 5.5.5.5, 64 hops max, press Ctrl+C to stop
 1   100.10.10.2   60.000 ms  30.000 ms  30.000 ms
 2   22.22.22.2   60.000 ms  40.000 ms  40.000 ms
 3   *210.16.16.1   72.000 ms

(Please note that as 5.5.5.5 is a loopback thats why
traceroute just stops here)

Anyhow see the path. PAckets are taking HSRP2 path.

 
Multihomed Border Gateway Protocol (BGP) network where you have connections to more then one separate Internet service providers (ISPs). In the event of a failure of connectivity toward one ISP, the traffic is rerouted dynamically through the other ISP with the Hot Standby Router Protocol (HSRP).
Picture
Requirements:
  • Configure IP Addresses on physical and vlan interfaces as per diagram
  • Configure HSRP on MLS1 and MLS2 so that MLS1 become HSRP Active and MLS2 will act as standby. MLS2 should take Active role if MLS one gets down or Interface between MLS1 and ISP goes down..
  • Configure EBGP neighbor relationship as required
  • Redistribute connected interfaces via BGP. MLS1 and MLS2 should not redistribute their connected interface
  • Send routing information of 100.10.10.0 network to all network routers via BGP.
  • Find result by pinging all interfaces and by finding traceroute of all interfaces

! MLS1HSRP1active Configuration
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
no shut

interface Vlan1
ip address 100.10.10.1 255.255.255.0
standby 10 ip 100.10.10.100
standby 10 priority 90
standby 10 preempt
standby 10 track FastEthernet0/0

router bgp 65222
network 100.10.10.0 mask 255.255.255.0
neighbor 1.1.1.2 remote-as 10

! ISP Configuration
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
no shut

interface Serial0/0
ip address 11.1.1.1 255.255.255.252
no shut

router bgp 10
redistribute connected
neighbor 1.1.1.1 remote-as 65222
neighbor 11.1.1.2 remote-as 20

! R8 Configuration
interface Serial0/0
ip address 11.1.1.2 255.255.255.252
no shut

interface Serial0/1
ip address 150.1.1.1 255.255.255.252
no shut

router bgp 20
redistribute connected
neighbor 11.1.1.1 remote-as 10
neighbor 150.1.1.2 remote-as 333

! R10 Configuration
interface Serial0/0
ip address 150.1.1.2 255.255.255.252
no shut

interface Serial0/1
ip address 170.1.1.1 255.255.255.252
no shut

interface Serial0/2
ip address 12.1.1.1 255.255.255.252
no shut

router bgp 333
redistribute connected
neighbor 12.1.1.2 remote-as 440
neighbor 150.1.1.1 remote-as 20
neighbor 170.1.1.2 remote-as 200
! MLS2HSRP2standby Configuration
interface FastEthernet0/0
ip address 2.2.2.1 255.255.255.252
no shut

interface Vlan1
ip address 100.10.10.2 255.255.255.0
standby 10 ip 100.10.10.100
standby 10 priority 50
standby 10 preempt
standby 10 track FastEthernet0/0

router bgp 65222
network 100.10.10.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 100

! ISP2 Configuration
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
no shut

interface Serial0/0
ip address 22.1.1.1 255.255.255.252
no shut

router bgp 100
redistribute connected
neighbor 2.2.2.1 remote-as 65222
neighbor 22.1.1.2 remote-as 200

! R9 Configuration
interface Serial0/0
ip address 22.1.1.2 255.255.255.252
no shut

interface Serial0/1
ip address 170.1.1.2 255.255.255.252
no shut

router bgp 200
redistribute connected
neighbor 22.1.1.1 remote-as 100
neighbor 170.1.1.1 remote-as 333

! Internet Configuration
interface Loopback0
ip address 44.44.44.44 255.255.255.255

interface Serial0/0
ip address 12.1.1.2 255.255.255.252
no shut

router bgp 440
redistribute connected
neighbor 12.1.1.1 remote-as 333

BGP Confederation

6/17/2013

 
BGP confederation is used to reduce iBGP mesh within an AS. We can use many smaller private Autonomous systems with in one confederation ID. Routers with in each private AS are configured with full ibgo mesh. Each private AS with in confederation will communicate to other private AS in same confederation via EBGP. Other Confederations and Autonomous systems will see and communicate via Confederation ID.
REQUIREMENT:
Configure IP addresses as given in topology
Configure loopback 0 on R1 (11.11.11.11/32) and R4 (44.44.44.44/32)
Configure static routes on R9. Routes are 99.99.99.0/30 ; 99.99.99.4/30 ; 99.99.99.8/30 ; 99.99.99.12/30
Configure IBGP and EBGP as per topology
Configure IGP as if required
Configure Confederations as per topology
Redistribute all static routes of R9 to BGP

Verification
Verify neighbor relationships
Verify routes and find if all networks are reachable from everyone
Verify bgp tables


Router 1 Configuration
R1#config terminal

R1(config)#interface serial 0/0

R1(config-if)#ip address 1.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#clock rate 64000

 

R1(config)#interface loopback 0

R1(config-if)#ip address 11.11.11.11 255.255.255.255

 

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#no auto-summary

R1(config-router)#network 1.1.1.0

 

R1(config)#router bgp 1

R1(config-router)#network 11.11.11.11 mask 255.255.255.255

R1(config-router)#neighbor 1.1.1.2 remote-as 2

 

 Router 2 Configuration

 R2#conf t

R2(config)#interface serial 0/0

R2(config-if)#no shutdown

R2(config-if)#ip address 50.1.1.1 255.255.255.0


R2(config)#interface serial 0/1

R2(config-if)#no shutdown

R2(config-if)#ip address 10.1.1.2 255.255.255.0


R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 10.1.1.0

R2(config-router)#network 50.1.1.0


R2(config)#router bgp 65502

R2(config-router)#neighbor 10.1.1.1 remote-as 65502

R2(config-router)#neighbor 50.1.1.2 remote-as 65504

R2(config-router)#bgp confederation identifier 2




R2(config-router)#bgp confederation peers 65504




Router 3 Configuration
R3#conf t

R3(config)#interface serial 0/0

R3(config-if)#no shutdown

R3(config-if)#ip address 50.1.1.2 255.255.255.0

 

R3(config)#interface serial 0/1

R3(config-if)#no shutdown

R3(config-if)#ip address 100.1.1.1 255.255.255.0

 

R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#no auto-summary

R3(config-router)#network 50.1.1.0

R3(config-router)#network 100.1.1.0

 

R3(config)#router bgp 65504

R3(config-router)#neighbor 50.1.1.1 remote-as 65502

R3(config-router)#neighbor 100.1.1.2 remote-as 65504

R3(config-router)#bgp confederation identifier 2





R3(config-router)#bgp confederation peers 65502

 

Router 4 Configuration
R4#conf t

R4(config)#interface serial 0/0

R4(config-if)#no shutdown

R4(config-if)#ip address 100.1.1.2 255.255.255.0

 

R4(config)#int serial 0/1

R4(config-if)#no shutdown

R4(config-if)#ip address 2.2.2.1 255.255.255.0

 

R4(config)#int loopback 0

R4(config-if)#ip add 44.44.44.44 255.255.255.255

 

R4(config)#router rip

R4(config-router)#no auto-summary

R4(config-router)#version 2

R4(config-router)#network 100.1.1.0

R4(config-router)#network 2.2.2.0

 

R4(config)#router bgp 65504

R4(config-router)#neighbor 100.1.1.1 remote-as 65504

R4(config-router)#neighbor 2.2.2.2 remote-as 20

R4(config-router)#network 44.44.44.44 255.255.255.255

R4(config-router)#bgp confederation identifier 2




R4(config-router)#bgp confederation peers 65502

 

Router 5 Configuration
R5#configure terminal

R5(config)#int serial 0/0

R5(config-if)#no shutdown

R5(config-if)#ip address 10.1.1.1 255.255.255.0

 

R5(config)#int serial 0/1

R5(config-if)#ip address 1.1.1.2 255.255.255.0

R5(config-if)#no shutdown

 

R5(config)#router rip

R5(config-router)#no auto-summary

R5(config-router)#version 2

R5(config-router)#network 1.1.1.0

R5(config-router)#network 10.1.1.0

 

R5(config)#router bgp 65502

R5(config-router)#neighbor 1.1.1.1 remote-as 1

R5(config-router)#neighbor 10.1.1.2 remote-as 65502

R5(config-router)#bgp confederation identifier 2




R5(config-router)#bgp confederation peers 65504

 



Router 6 Configuration
 

 

R6#conf t

R6(config)#interface serial 0/0

R6(config-if)#ip address 2.2.2.2 255.255.255.0

 

R6(config)#interface serial 0/1

R6(config-if)#no shutdown

R6(config-if)#ip address 100.100.100.1 255.255.255.0

 

R6(config)#router rip

R6(config-router)#no auto-summary

R6(config-router)#version 2

R6(config-router)#network 2.2.2.0

R6(config-router)#network 100.100.100.0

 

R6(config)#router bgp 65504

R6(config-router)#neighbor 2.2.2.1 remote-as 2

R6(config-router)#neighbor 100.100.100.2 remote-as 65505

R6(config-router)#bgp confederation identifier 20




R6(config-router)#bgp confederation peers 65505


 



Router 7 Configuration
R7#conf t

R7(config)#interface serial 0/0

R7(config-if)#no shutdown

R7(config-if)#ip address 100.100.100.2 255.255.255.0

 

R7(config)#interface serial 0/1

R7(config-if)#no shutdown

R7(config-if)#ip address 10.10.10.1 255.255.255.0

 

R7(config)#router rip

R7(config-router)#no auto-summary

R7(config-router)#version 2

R7(config-router)#network 100.100.100.0

R7(config-router)#network 10.10.10.0

 

R7(config)#router bgp 65505

R7(config-router)#neighbor 10.10.10.2 remote-as 65502

R7(config-router)#neighbor 100.100.100.1 remote-as 65504

R7(config-router)#bgp confederation identifier 20




R7(config-router)#bgp confederation peers 65502 65504






Router 8 Configuration
R8#conf t

R8(config)#interface serial 0/0

R8(config-if)#no shutdown

R8(config-if)#ip address 10.10.10.2 255.255.255.0

 

R8(config)#interface serial 0/1

R8(config-if)#no shutdown

R8(config-if)#ip address 1.1.2.1 255.255.255.0

 

R8(config)#router rip

R8(config-router)#no auto-summary

R8(config-router)#version 2

R8(config-router)#network  10.10.10.0

R8(config-router)#network  1.1.2.0

 

R8(config)#router bgp 65502

R8(config-router)#neighbor 10.10.10.1 remote-as 65505

R8(config-router)#neighbor 1.1.2.2 remote-as 30

R8(config-router)#bgp confederation identifier 20




R8(config-router)#bgp confederation peers 65505

 




Router 9 Configuration
R9#conf t

R9(config)#interface serial 0/0

R9(config-if)#no shutdown

R9(config-if)#ip address 1.1.2.2 255.255.255.0

 

R9(config)#ip route 99.99.99.0 255.255.255.252 null 0

R9(config)#ip route 99.99.99.4 255.255.255.252 null 0

R9(config)#ip route 99.99.99.8 255.255.255.252 null 0

R9(config)#ip route 99.99.99.12 255.255.255.252 null 0

 

R9(config)#router rip

R9(config-router)#no auto-summary

R9(config-router)#version 2

R9(config-router)#network 1.1.2.0

 

R9(config)#router bgp 30

R9(config-router)#neighbor 1.1.2.1 remote-as 20

R9(config-router)#redistribute static


Configuration Explanation


Providing IP addresses to serial 0/0 interface









Providing IP addresses to Loopback0 interface





We are introducing RIP protocol as IGP.

version 2 for classless routing or discontegeous network support
Propagate subnets rather summary address






Configuring BGP AS 1

Propagating 11.11.11.11 via BGP


Making neighbor relationship with 1.1.1.2 of R5 in confederation 2

Configuration Explanation



Providing IP address to S 0/0






Providing IP address to S 0/1






Running RIP as IGP (Interior gateway protocol)










Running BGP with private AS 65502

Making neighbor relationship with 10.1.1.1

Making neighbor relationship with 50.1.1.2

This command is used to tell BGP that this private AS (65502) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65502) has peer relationship with another private AS (65504) of same confederation 2



Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 50.1.1.1

Making neighbor relationship with 100.1.1.2

This command is used to tell BGP that this private AS (65504) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65504) has peer relationship with another private AS (65502) of same confederation 2



Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Providing ip address to loopback 0





Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 100.1.1.1

Making neighbor relationship with 2.2.2.2




This command is used to tell BGP that this private AS (65504) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65504) has peer relationship with another private AS (65502) of same confederation 2

Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65502

Making neighbor relationship with 1.1.1.1

Making neighbor relationship with 10.1.1.2

This command is used to tell BGP that this private AS (65504) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65502) has peer relationship with another private AS (65504) of same confederation 2



Configuration Explanation






Providing IP address to S 0/0





Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 2.2.2.1

Making neighbor relationship with 100.100.100.2

This command is used to tell BGP that this private AS (65504) is a member of confederation 20. confederation AS 20 will be used to communicate outer world.

This command is telling router that our private AS (65504) has peer relationship with another private AS (65505) of same confederation 2




Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 10.10.10.2


Making neighbor relationship with 100.100.100.1

This command is used to tell BGP that this private AS (65505) is a member of confederation 20. confederation AS 20 will be used to communicate outer world.

This command is telling router that our private AS (65505) has peer relationship with two other private AS (65502 and 65504) of same confederation 2




Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65502

Making neighbor relationship with 10.10.10.1


Making neighbor relationship with 1.1.2.2

This command is used to tell BGP that this private AS (65502) is a member of confederation 20. confederation AS 20 will be used to communicate outer world.

This command is telling router that our private AS (65502) has peer relationship with another private AS (65505) of same confederation 20




Configuration Explanation


Providing IP address to S 0/0







Static IP routes null 0 interface









Running RIP as IGP (Interior gateway protocol)









Running BGP with AS 30

Making neighbor relationship with 1.1.2.1

Redistributing static routes
Now we will examine routing table of routers by show ip route command. I will only check R1 and R9 as if they are having good all routes then things will likely be OK in between but you should check during learning process all routers routing table
I am ending this lab over here. You can also try two commands

Show ip bgp summary
Debug ip bgp
 
Picture
Requirement:
  1. Configure IP Addresses on interfaces
  2. Configure R1 loopback 10.1.1.1 ; R2 loopback 20.1.1.1 ; R3 loopback 30.1.1.1
  3. Configure static route on R1 and redistribute it to bgp
  4. Configure IBGP AS 20 on all routers
  5. Make neighbor relationship
  6. BGP split horizon will not allow R2 to propagate one neighbor's route to other.





Look into routing tables and neighbor tables of bgp. Try to find interesting results.

Verification commands:
Show ip route
Show ip bgp summary
Show ip bgp
Debug ip bgp                   => Always use this command to verify and learn

Router 1 Configuration

R1(config)#interface Loopback0
R1(config-if)# ip address 10.1.1.1 255.255.255.0

R1(config-if)#interface Serial0/0
R1(config-if)# ip address 1.1.1.1 255.255.255.252
R1(config-if)# clock rate 64000
R1(config-if)#no shutdown

R1(config-if)#ip route 12.12.12.12 255.255.255.255 Null0

R1(config)#router bgp 20
R1(config-router)# network 1.1.1.0 mask 255.255.255.252
R1(config-router)# network 10.1.1.0 mask 255.255.255.0
R1(config-router)# redistribute static
R1(config-router)# neighbor 1.1.1.2 remote-as 20

Router 2 Configuration
R2#conf t
R2(config)#interface Loopback0
R2(config-if)# ip address 20.1.1.1 255.255.255.0

R2(config-if)#interface Serial0/0
R2(config-if)# ip address 1.1.1.2 255.255.255.252
R2(config-if)# clock rate 2000000
R2(config-if)#no shutdown

R2(config-if)#interface Serial0/1
R2(config-if)# ip address 2.2.2.1 255.255.255.252
R2(config-if)# clock rate 64000
R2(config-if)#no shutdown

R2(config)#router bgp 20
R2(config-router)# network 1.1.1.0 mask 255.255.255.252
R2(config-router)# network 2.2.2.0 mask 255.255.255.252
R2(config-router)# network 20.1.1.0 mask 255.255.255.0
R2(config-router)# neighbor 1.1.1.1 remote-as 20
R2(config-router)# neighbor 2.2.2.2 remote-as 20


Router 3 Configuration
R3(config)#interface Loopback0
R3(config-if)# ip address 30.1.1.1 255.255.255.0

R3(config-if)#interface Serial0/0
R3(config-if)# ip address 2.2.2.2 255.255.255.252
R3(config-if)#no shut

R3(config-if)#router bgp 20
R3(config-router)# network 2.2.2.0 mask 255.255.255.252
R3(config-router)# network 30.1.1.0 mask 255.255.255.0
R3(config-router)# neighbor 2.2.2.1 remote-as 20

Configuration Explanation

Configuring loop back interface


Configuring serial 0/0 interface




Static route to Null 0 interface


Configuring BGP for Autonomous system 20
Propagating network 1.1.1.0

Propagating network 10.1.1.0

Redistributing static routes to BGP
Making neighbor relationship with 1.1.1.2 of R2



Configuring loop back interface


Configuring serial 0/0 interface




Configuring serial 0/1 interface




Configuring BGP for Autonomous system 20
Propagating network 1.1.1.0

Propagating network 2.2.2.0

Propagating network 20.1.1.0

Making neighbor relationship with 1.1.1.1 of R1
Making neighbor relationship with 2.2.2.2 of R3



Configuring Loopback 0 interface


Configuring serial 0/0 interface



Configuring BGP 20
Propagating network 2.2.2.0

Propagating network 30.1.1.0

Making neighbor relationship with 2.2.2.1 of R2
Picture
Verification Command

R1# Show ip route
R2# Show ip route
R3# Show ip route










R2 has all routes from R1 and R3 but due to split horizon rule; R2 is not sending R1's route to R3 and R3 routes to R1


Let's see neighbor table of all three routers
Picture
Command

R1# Show ip bgp summary
R2# Show ip bgp summary
R3# Show ip bgp summary

Let's see all possible routes of BGP. Look at following snapshot
Picture
This output is showing Router ID.
* means all valid routes
> means best route between all possible routes to a network

EBGP Lab no 1

6/12/2013

 
Picture
In this Lab, We are configuring all three routers in three different autonomous systems and making them EBGP neighbor.









Basic Configuration of Topology

R1 (Router 1)
interface Loopback0
ip address 10.1.1.1 255.255.255.0

interface Serial0/0
ip address 1.1.1.1 255.255.255.252
clock rate 64000
no sh

router bgp 1
network 1.1.1.0 mask 255.255.255.252
network 10.1.1.0 mask 255.255.255.0
neighbor 1.1.1.2 remote-as 2

Router: 2


interface Loopback0
ip address 20.1.1.1 255.255.255.0

interface Serial0/0
ip address 1.1.1.2 255.255.255.252
clock rate 64000
no sh

interface Serial0/1
ip address 2.2.2.1 255.255.255.252
clock rate 64000
no sh

router bgp 2
network 1.1.1.0 mask 255.255.255.252
network 2.2.2.0 mask 255.255.255.252
network 20.1.1.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 1
neighbor 2.2.2.2 remote-as 3

Router-3
interface Loopback0
ip address 30.1.1.1 255.255.255.0

interface Serial0/0
ip address 2.2.2.2 255.255.255.252
clock rate 64000
no sh

router bgp 3
network 2.2.2.0 mask 255.255.255.252
network 30.1.1.0 mask 255.255.255.0
neighbor 2.2.2.1 remote-as 2

Verification Commands:
For routing table: Show ip route
For BGP neighbour relationship: show ip bgp summary
For BGP full routing information: Show ip bgp