In this scenario; We are trying to built a topology in which four customers wanna communicate each other via frame relay cloud. Normally labs are done with one FR device but what about when we are working as a WAN service provider having so many devices in their cloud. Let's see how customers of TelcoRemote2 will communicate to customer of TelcoKHI.

We will built a tunnel for this purpose and use OSPF as a routing protocol between Cloud. Let's see detail
Picture
Requirement:

  • Configure all IP addresses as per topology
  • Assign DLCI's to all customers
  • Assign Route to all customers so that they will communicate each other seamlessly
  • Configure OSPF area 0 for network 10.1.1.0 and 20.1.1.0
  • Configure tunnel so that Remote customer can communicate to Site1, 2 and 3 customers.
  • Verify connectivity with
    ping command
    show frame-relay map
    show frame-relay route
    show frame-relay pvc
    debug frame-relay packet
    debug frame-relay pvc
    debug frame-relay event

!CustomerSite1 Configuration

interface Serial0/0
ip address 1.1.1.1 255.255.255.0
encapsulation frame-relay



frame-relay interface-dlci 101
frame-relay interface-dlci 102
frame-relay interface-dlci 103
frame-relay interface-dlci 104
no shut

!CustomerSite2 Configuration

interface Serial0/0
ip address 2.2.2.2 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 201
frame-relay interface-dlci 202
frame-relay interface-dlci 203
frame-relay interface-dlci 204
no shut

! CustomerSite3 Configuration

interface Serial0/0
ip address 3.3.3.3 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 301
frame-relay interface-dlci 302
frame-relay interface-dlci 303
frame-relay interface-dlci 304
no shut

! Telco remote2 Configuration

frame-relay switching




interface Serial0/0
no ip address

encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce

frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
frame-relay route 104 interface Tunnel0 401
no shut

interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
frame-relay route 203 interface Serial0/2 302
frame-relay route 204 interface Tunnel0 402
no shut

interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
frame-relay route 302 interface Serial0/1 203
frame-relay route 304 interface Tunnel0 403
no shut

interface fastethernet 0/0
ip address 10.1.1.1 255.255.255.252
no shut

interface tunnel 0
no ip address
tunnel source 10.1.1.1
tunnel destination 20.1.1.1

Router OSPF 10
network 10.1.1.0 0.0.0.3 area 0

! R7 Configuration

interface fastethernet 0/0
ip address 10.1.1.2 255.255.255.252
no shut

interface fastethernet 0/1
ip address 20.1.1.2 255.255.255.252
no shut

Router OSPF 10
network 10.1.1.0 0.0.0.3 area 0
network 20.1.1.0 0.0.0.3 area 0


! Telco KHI Configuration

frame-relay switching

interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce

! Note both dlcis are same in all routes
frame-relay route 401 interface Tunnel0 401
frame-relay route 402 interface Tunnel0 402
frame-relay route 403 interface Tunnel0 403

no shut

interface fastethernet 0/0
ip address 20.1.1.1 255.255.255.252
no shut

interface tunnel 0
no ip address
tunnel source 20.1.1.1
tunnel destination 10.1.1.1

Router OSPF 10
network 20.1.1.0 0.0.0.3 area 0


! RemoteCustomer Configuration

interface Serial0/0
ip address 15.15.15.1 255.255.255.0
encapsulation frame-relay
frame-relay interface-dlci 401
frame-relay interface-dlci 402
frame-relay interface-dlci 403
frame-relay interface-dlci 404
no shut



Configuration Explanation


Configuring IP on customer interface
encapsulation frame-relay command sets the frame encapsulation type. There are two types of Frame Relay encapsulations: Cisco and IETF. Cisco is the default.

We are putting many DLCI's to one physical serial interface.









See Site1 Explanation










See Site1 Explanation






This is a key command on FR switches on service provider side. Forget this command; Forget FR switching. Anyhow; If you try to configure interface type dce without this; you will get error.


As this interface word as a FR enabled interface; it donot require IP address.
Setting encapsulation type
Setting clock rate
FR switch interface must be DCE

This command is telling that DLCI 102, 103, 104 should route toward said interface



























Creating tunnel from source 10.1.1.1 (interface F0/0) to destination 20.1.1.1 (int F0/0)
































This is a key for tunneling Frame relay. Both DLCI's should be same in each command else you will find status Inactive
 
Requirement:
  • Configure IP addresses as per diagram
  • Configure loopback addresses as per diagram
  • All routers must reach every route in the network
  • How many virtual links and tunnels we need to configure for this topology so that R8 will have all routes and why?
    1. 1 virtual link
    2. 2 virtual link
    3. 1 virtual link and 1 tunnel
    4. More then 2 virtual links
  • Test connectivity by ping
  • How many pings do we need to reach all networks from R8? Can pinging 255.255.255.255 will help us reach all networks in one go? If yes Why and If no then why not?
  • Verify configuration by using following commands
    1. Show ip route
    2. show ip eigrp interfaces
    3. show ip eigrp neighbors
    4. show ip eigrp topology
    5. show ip eigrp traffic
    6. show ip protocol
    7. show ip ospf border-routers
    8. show ip ospf database
    9. show ip ospf interface
    10. show ip ospf neighbor
    11. show ip ospf virtual-links
    12. show ip rip database
! R1 configuration

interface Loopback0
 ip address 10.1.1.1 255.255.255.0
no shut

interface Loopback1
 ip address 10.1.2.1 255.255.255.0
no shut

interface FastEthernet0/0
 ip address 7.7.7.2 255.255.255.252
no shut

interface Serial0/0
 ip address 1.1.1.1 255.255.255.252
no shut

router eigrp 100
 network 1.0.0.0
 network 10.0.0.0
 no auto-summary

router ospf 1
 network 7.7.7.0 0.0.0.3 area 0




! R3 configuration

interface Loopback5
 ip address 30.1.1.1 255.255.255.0

interface Loopback6
 ip address 30.1.30.1 255.255.255.0

interface FastEthernet0/1
 ip address 6.6.6.2 255.255.255.252
no shut

interface Serial0/1
 ip address 3.3.3.1 255.255.255.252
no shut

router eigrp 100
 redistribute rip metric 10 10 10 10 10
 redistribute ospf 1 metric 10 10 10 10 10
 network 3.0.0.0
 no auto-summary

router ospf 1
 redistribute eigrp 100 metric 10 subnets
 redistribute rip metric 10 subnets
 network 6.6.6.0 0.0.0.3 area 0

router rip
 version 2
 redistribute eigrp 100 metric 10
 redistribute ospf 1 metric 10
 network 2.0.0.0
 network 30.0.0.0
 no auto-summary


! R5 configuration

interface Loopback59
 ip address 59.1.1.1 255.255.255.0

interface Loopback69
 ip address 69.1.1.1 255.255.255.0

interface Loopback79
 ip address 79.1.1.1 255.255.255.0

interface Serial0/0
 ip address 5.5.5.2 255.255.255.252
no shut

interface Serial0/1
 ip address 4.4.4.2 255.255.255.252
no shut

router ospf 1
 area 1 virtual-link 40.1.40.1
 network 4.4.4.0 0.0.0.3 area 1
 network 5.5.5.0 0.0.0.3 area 0
 network 59.1.1.0 0.0.0.255 area 0
 network 69.1.1.0 0.0.0.255 area 0
 network 79.1.1.0 0.0.0.255 area 1







! R7 configuration

interface FastEthernet0/0
 ip address 200.1.1.2 255.255.255.252
no shut

interface Serial0/0
 ip address 210.1.1.1 255.255.255.252
 clock rate 64000
no shut

router ospf 1
 log-adjacency-changes
 area 2 virtual-link 40.1.40.1
 network 200.1.1.0 0.0.0.3 area 2
 network 210.1.1.0 0.0.0.3 area 3
! R2 configuration

interface Loopback9
 ip address 20.1.1.1 255.255.255.0

interface Loopback10
 ip address 20.1.10.1 255.255.255.0

interface Serial0/0
 ip address 1.1.1.2 255.255.255.252
no shut

interface Serial0/1
 ip address 2.2.2.1 255.255.255.252
no shut

router eigrp 100
 redistribute rip metric 10 10 10 10 10
 network 1.0.0.0
 network 20.0.0.0
 no auto-summary

router rip
 version 2
 redistribute eigrp 100 metric 10
 network 2.0.0.0
 no auto-summary


! R4 configuration

interface Loopback100
 ip address 40.1.1.1 255.255.255.0

interface Loopback101
 ip address 40.1.40.1 255.255.255.0

interface FastEthernet0/0
 ip address 200.1.1.1 255.255.255.252
no shut

interface Serial0/0
 ip address 3.3.3.2 255.255.255.252
no shut

interface Serial0/1
 ip address 4.4.4.1 255.255.255.252
no shut

router eigrp 100
 network 3.0.0.0
 network 40.0.0.0
 no auto-summary

router ospf 1
 area 1 virtual-link 79.1.1.1
 area 2 virtual-link 210.1.1.1
 network 4.4.4.0 0.0.0.3 area 1
 network 200.1.1.0 0.0.0.3 area 2






! R6 configuration

interface Loopback59
 ip address 130.0.0.1 255.255.255.0

interface Loopback69
 ip address 140.0.0.1 255.255.255.0

interface Loopback89
 ip address 150.0.0.1 255.255.255.0

interface FastEthernet0/0
 ip address 7.7.7.1 255.255.255.252
no shut

interface Serial0/0
 ip address 5.5.5.1 255.255.255.252
 clock rate 64000
no shut

interface FastEthernet0/1
 ip address 6.6.6.1 255.255.255.252
no shut

router ospf 1
 network 5.5.5.0 0.0.0.3 area 0
 network 6.6.6.0 0.0.0.3 area 0
 network 7.7.7.0 0.0.0.3 area 0
 network 130.0.0.0 0.0.0.255 area 0
 network 140.0.0.0 0.0.0.255 area 1
 network 150.0.0.0 0.0.0.255 area 0


! R8 configuration

interface Serial0/0
 ip address 210.1.1.2 255.255.255.252
no shut

router ospf 1
 network 210.1.1.0 0.0.0.3 area 3
 
Picture
OSPF stands for Open Shortest Path First. It is an internal routing protocol of the autonomous system based on link state. Routers running the SPF (Shortest Path First) algorithm Dijkshtra to be precise build a shortest path tree that takes itself as the root, and the tree gives out the route to nodes in the autonomous system.

Within OSPF there can be Point-to-Point networks or Multi-Access networks. The Multi-Access networks could be one of the following:

  • Broadcast Network: A single message can be sent to all routers
  • Non-Broadcast Multi-Access (NBMA) Network: Has no broadcast ability, ISDN, ATM, Frame Relay and X.25 are examples of NBMA networks.
  • Point to Multipoint Network: Used in group mode Frame Relay networks.

Requirement:
  • Enable and configure interfaces as per topology diagram
  • Configure one loop back addresses on each router
  • Configure OSPF area 0 on both routers so that they both can get all routes

! R2 Configuration

interface Loopback0
ip address 10.1.1.1 255.255.255.0

interface Serial0/0
ip address 1.1.1.1 255.255.255.252
no shut

router ospf 10
network 1.1.1.0 0.0.0.3 area 0
network 10.1.1.0 0.0.0.255 area 0

! R3 Configuration

interface Loopback0
 ip address 100.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 1.1.1.2 255.255.255.252
no shut
!
router ospf 10
 network 1.1.1.0 0.0.0.3 area 0
 network 100.1.1.1 0.0.0.0 area 0

Verification commands

R2#show ip ospf neighbor       ==========> To find out information about OSPF neighbors
Neighbor ID     Pri   State           Dead Time   Address         Interface
100.1.1.1         0   FULL/  -        00:00:36    1.1.1.2         Serial0/0
Look at the neighbor ID; its the loopback address

R3#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
10.1.1.1          0   FULL/  -        00:00:30    1.1.1.1         Serial0/0
Look at the neighbor ID; its the loopback address


R2#show ip route ospf                         ==========> Only OSPF routes
     100.0.0.0/32 is subnetted, 1 subnets
O       100.1.1.1 [110/65] via 1.1.1.2, 00:34:12, Serial0/0

R3#show ip route ospf
     10.0.0.0/32 is subnetted, 1 subnets
O       10.1.1.1 [110/65] via 1.1.1.1, 00:34:12, Serial0/0


R2#show ip route                          ==========> ALL routes coming to routing table
Gateway of last resort is not set
     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Serial0/0
     100.0.0.0/32 is subnetted, 1 subnets
O       100.1.1.1 [110/65] via 1.1.1.2, 00:36:01, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback0

R3#show ip route
Gateway of last resort is not set
     1.0.0.0/30 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Serial0/0
     100.0.0.0/32 is subnetted, 1 subnets
C       100.1.1.1 is directly connected, Loopback0
     10.0.0.0/32 is subnetted, 1 subnets
O       10.1.1.1 [110/65] via 1.1.1.1, 00:36:01, Serial0/0


R2#show ip protocols
Routing Protocol is "ospf 10"                 ==========> This is OSPF process ID
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 10.1.1.1                            ==========> Router ID
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.1.1.0 0.0.0.3 area 0
    10.1.1.0 0.0.0.7 area 0
    10.1.1.0 0.0.0.255 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    100.1.1.1            110      00:38:01      ==========> Administrative distance
  Distance: (default is 110)                    ==========> OSPF default Administrative distance

R3#show ip protocols
Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 100.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.1.1.0 0.0.0.3 area 0
    100.1.1.1 0.0.0.0 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.1.1             110      00:38:01
  Distance: (default is 110)


 
ODR is not a routing protocol but an enhancement to CDP as it can propogate prefixes and only add 5 bytes into CDP. ODR must only be enabled on stub router. ODR will not work if other routing protocols are running. CDP should be running on all routers. We need to run ODR on hub router and all other spokes send their connected interfaces information to Hub via ODR (CDP update). Please note that we cannot redistribute static or dynamic routes to ODR but can redistribute ODR routes to dunamic protocols.

You can also load balance via ODR if you have multiple Hubs.

Picture
Requirement:
  • In this topology R3 is a spoke and R2 is a Hub. We will  running EIGRP between R1 and R2.
  • R3 should send its loop-back (connected interfaces) information to the whole network without using static routing or dynamic routing protocols.
  • R3 should learn EIGRP routes



! R1 Configuration
interface FastEthernet0/0
ip address 1.1.1.1 255.0.0.0
no shut

router eigrp 10
network 1.0.0.0


! R2 Configuration

router odr



interface FastEthernet0/0
ip address 1.1.1.2 255.0.0.0
no shutdown

interface Serial0/0
ip address 2.2.2.1 255.0.0.0
no shutdown

router eigrp 10
network 1.0.0.0
redistribute odr metric 10 10 10 10 10


! R3 Configuration

interface Loopback0
ip address 40.1.1.1 255.255.255.255

interface Loopback1
ip address 40.1.1.2 255.255.255.255

interface Serial0/0
ip address 2.2.2.2 255.0.0.0
no shutdown
Configuration Explanation










This command is letting R2 to send itself as a default route to all spoke routers i.e. R1 and will get connected information update from neighbors CDP update










Redistributing ODR routes to EIGRP




Connected loopback interface


Connected loopback interface





Verification

R3#show ip route odr
o*   0.0.0.0/0 [160/1] via 2.2.2.1, 00:00:45, Serial0/0

R3#show ip route
Gateway of last resort is 2.2.2.1 to network 0.0.0.0

C    2.0.0.0/8 is directly connected, Serial0/0
     40.0.0.0/32 is subnetted, 2 subnets
C       40.1.1.1 is directly connected, Loopback0
C       40.1.1.2 is directly connected, Loopback1
o*   0.0.0.0/0 [160/1] via 2.2.2.1, 00:00:13, Serial0/0

This output shows that by configuring R2 as ODR; R1 (spoke) gets default route toward hub (R2)


R2#show ip route

C    1.0.0.0/8 is directly connected, FastEthernet0/0
C    2.0.0.0/8 is directly connected, Serial0/0
     40.0.0.0/32 is subnetted, 2 subnets
o       40.1.1.1 [160/1] via 2.2.2.2, 00:00:30, Serial0/0
o       40.1.1.2 [160/1] via 2.2.2.2, 00:00:30, Serial0/0

R2 has learnt both ODR routes from CDP update

R1#show ip route
C    1.0.0.0/8 is directly connected, FastEthernet0/0
     40.0.0.0/32 is subnetted, 2 subnets
D EX    40.1.1.1 [170/256028160] via 1.1.1.2, 00:00:37, FastEthernet0/0
D EX    40.1.1.2 [170/256028160] via 1.1.1.2, 00:00:37, FastEthernet0/0


Redistributed ODR routes to EIGRP
 
Picture
Requirement:
Bat-man router F0/0 should get IP address from DHCP server configured on DHCP-Switch. Let's see how we can do it

Device Configuration

! batman-router
interface FastEthernet0/0
ip address dhcp
speed 100
full-duplex
no shut


! DHCP-SWITCH Configuration
hostname DHCP-SWITCH

interface fastEthernet 1/0
no shut
speed 100
duplex full
switchport access vlan 5

int vlan 5
ip add 20.10.10.1 255.255.255.0
no shut
exit

ip routing
ip dhcp excluded-address 20.10.10.1 20.10.10.3



ip dhcp pool dhcp-pool
network 20.10.10.0 255.255.255.128
default-router 20.10.10.1


domain-name dhcp.com.pk
lease 1 12



Explanation



Assign IP address via DHCP. When DHCP client will boot, the client will begin sending packets to its default router. The IP address of the default router should be on the same subnet as the client.



Changing Host name

This is a switch interface



Creating vlan. We will assign this vlan ip as adefault gateway address

Assigning ip to SVI interface




Address to exclude from ip pool. Actually we are already using or have to use these addresses in future and we donot want dhcp to assign these ip addresses to any other client
Assigning dhcp pool name
Assigning ip addresses to dhcp pool
This command will make 20.10.10.1 as a default gateway and propagate this information to all neighbors
Assigning domain name
IP lease time is 1 day and 12 hours

Verification of DHCP IP assignment and detailed debugging

batman-router#sh ip route

Gateway of last resort is 20.10.10.1 to network 0.0.0.0
Have you noticed gateway of last resort. This is due to default-router command configured on dhcp-switch
     20.0.0.0/25 is subnetted, 1 subnets
C       20.10.10.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [254/0] via 20.10.10.1
Have you noticed default route. This is due to default-router command configured on dhcp-switch



batman-router#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            20.10.10.5      YES DHCP   up                    up



batman-router#debug dhcp detail

*Mar  1 00:17:37.179: DHCP: DHCP client process started: 10
*Mar  1 00:17:37.211: RAC: Starting DHCP discover on FastEthernet0/0
*Mar  1 00:17:37.211: DHCP: Try 1 to acquire address for FastEthernet0/0
*Mar  1 00:17:37.239: DHCP: allocate request
*Mar  1 00:17:37.243: DHCP: zapping entry in DHC_PURGING state for Fa0/0
*Mar  1 00:17:37.243: DHCP: deleting entry 673E86B4 20.10.10.4 from list
*Mar  1 00:17:37.247: Temp IP addr: 20.10.10.4  for peer on Interface: FastEthernet0/0
*Mar  1 00:17:37.251: Temp  sub net mask: 255.255.255.128
*Mar  1 00:17:37.251:    DHCP Lease server: 20.10.10.1, state: 11 Purging
*Mar  1 00:17:37.255:    DHCP transaction id: 2B5
*Mar  1 00:17:37.255:    Lease: 129600 secs,  Renewal: 64800 secs,  Rebind: 113400 secs
*Mar  1 00:17:37.259:    Next timer fires after: 00:00:24
*Mar  1 00:17:37.263:    Retry count: 0   Client-ID: cisco-c400.04b8.0000-Fa0/0
*Mar  1 00:17:37.263:    Client-ID hex dump: 636973636F2D633430302E303462382E
*Mar  1 00:17:37.275:                        303030302D4661302F30
*Mar  1 00:17:37.283:    Hostname: Router
*Mar  1 00:17:37.287: DHCP: new entry. add to queue, interface FastEthernet0/0
*Mar  1 00:17:37.291: DHCP: SDiscover attempt # 1 for entry:
*Mar  1 00:17:37.291: Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet0/0
*Mar  1 00:17:37.295: Temp  sub net mask: 0.0.0.0
*Mar  1 00:17:37.295:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Mar  1 00:17:37.299:    DHCP transaction id: 20C2
*Mar  1 00:17:37.303:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Mar  1 00:17:37.303:    Next timer fires after: 00:00:04
*Mar  1 00:17:37.307:    Retry count: 1   Client-ID: cisco-c400.04b8.0000-Fa0/0
*Mar  1 00:17:37.307:    Client-ID hex dump: 636973636F2D633430302E303462382E
*Mar  1 00:17:37.319:                        303030302D4661302F30
*Mar  1 00:17:37.327:    Hostname: batman-router
*Mar  1 00:17:37.331: DHCP: SDiscover: sending 302 byte length DHCP packet
*Mar  1 00:17:37.331: DHCP: SDiscover 302 bytes
*Mar  1 00:17:37.335:             B'cast on FastEthernet0/0 interface from 0.0.0.0
*Mar  1 00:17:39.163: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar  1 00:17:39.767: DHCP: Received a BOOTREP pkt
*Mar  1 00:17:39.771: DHCP: Scan: Message type: DHCP Offer
*Mar  1 00:17:39.775: DHCP: Scan: Server ID Option: 20.10.10.1 = 140A0A01

*Mar  1 00:17:39.775: DHCP: Scan: Lease Time: 129600
*Mar  1 00:17:39.779: DHCP: Scan: Renewal time: 64800
*Mar  1 00:17:39.779: DHCP: Scan: Rebind time: 113400
*Mar  1 00:17:39.783: DHCP: Scan: Subnet Address Option: 255.255.255.128
*Mar  1 00:17:39.783: DHCP: Scan: Router Option: 20.10.10.1
*Mar  1 00:17:39.787: DHCP: Scan: Domain Name: dhcp.com.pk
*Mar  1 00:17:39.787: DHCP: rcvd pkt source: 20.10.10.1,  destination:  255.255.255.255

*Mar  1 00:17:39.791:    UDP  sport: 43,  dport: 44,  length: 308
*Mar  1 00:17:39.795:    DHCP op: 2, htype: 1, hlen: 6, hops: 0
*Mar  1 00:17:39.795:    DHCP server identifier: 20.10.10.1
*Mar  1 00:17:39.799:         xid: 20C2, secs: 0, flags: 8000
*Mar  1 00:17:39.799:         client: 0.0.0.0, your: 20.10.10.5
*Mar  1 00:17:39.803:         srvr:   0.0.0.0, gw: 0.0.0.0
*Mar  1 00:17:39.803:         options block length: 60

*Mar  1 00:17:39.807: DHCP Offer Message   Offered Address: 20.10.10.5
*Mar  1 00:17:39.811: DHCP: Lease Seconds: 129600    Renewal secs:  64800    Rebind secs:   1                                                                          13400
*Mar  1 00:17:39.815: DHCP: Server ID Option: 20.10.10.1
*Mar  1 00:17:39.815: DHCP: offer received from 20.10.10.1

*Mar  1 00:17:39.819: DHCP: SRequest attempt # 1 for entry:
*Mar  1 00:17:39.819: Temp IP addr: 20.10.10.5  for peer on Interface: FastEthernet0/0
*Mar  1 00:17:39.823: Temp  sub net mask: 255.255.255.128
*Mar  1 00:17:39.823:    DHCP Lease server: 20.10.10.1, state: 4 Requesting
*Mar  1 00:17:39.823:    DHCP transaction id: 20C2
*Mar  1 00:17:39.823:    Lease: 129600 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Mar  1 00:17:39.823:    Next timer fires after: 00:00:03
*Mar  1 00:17:39.823:    Retry count: 1   Client-ID: cisco-c400.04b8.0000-Fa0/0
*Mar  1 00:17:39.823:    Client-ID hex dump: 636973636F2D633430302E303462382E
*Mar  1 00:17:39.823:                        303030302D4661302F30
*Mar  1 00:17:39.823:    Hostname: batman-router
*Mar  1 00:17:39.823: DHCP: SRequest- Server ID option: 20.10.10.1
*Mar  1 00:17:39.823: DHCP: SRequest- Requested IP addr option: 20.10.10.5

*Mar  1 00:17:39.823: DHCP: SRequest placed lease len option: 129600
*Mar  1 00:17:39.823: DHCP: SRequest: 320 bytes
*Mar  1 00:17:39.823: DHCP: SRequest: 320 bytes
*Mar  1 00:17:39.827:             B'cast on FastEthernet0/0 interface from 0.0.0.0
*Mar  1 00:17:39.911: DHCP: Received a BOOTREP pkt
*Mar  1 00:17:39.911: DHCP: Scan: Message type: DHCP Ack
*Mar  1 00:17:39.915: DHCP: Scan: Server ID Option: 20.10.10.1 = 140A0A01
*Mar  1 00:17:39.915: DHCP: Scan: Lease Time: 129600
*Mar  1 00:17:39.919: DHCP: Scan: Renewal time: 64800
*Mar  1 00:17:39.919: DHCP: Scan: Rebind time: 113400
*Mar  1 00:17:39.923: DHCP: Scan: Subnet Address Option: 255.255.255.128
*Mar  1 00:17:39.923: DHCP: Scan: Router Option: 20.10.10.1
*Mar  1 00:17:39.927: DHCP: Scan: Domain Name: dhcp.com.pk
*Mar  1 00:17:39.931: DHCP: rcvd pkt source: 20.10.10.1,  destination:  255.255.255.255

*Mar  1 00:17:39.931:    UDP  sport: 43,  dport: 44,  length: 308
*Mar  1 00:17:39.935:    DHCP op: 2, htype: 1, hlen: 6, hops: 0
*Mar  1 00:17:39.935:    DHCP server identifier: 20.10.10.1
*Mar  1 00:17:39.939:         xid: 20C2, secs: 0, flags: 8000
*Mar  1 00:17:39.939:         client: 0.0.0.0, your: 20.10.10.5
*Mar  1 00:17:39.943:         srvr:   0.0.0.0, gw: 0.0.0.0
*Mar  1 00:17:39.947:         options block length: 60

*Mar  1 00:17:39.947: DHCP Ack Message
*Mar  1 00:17:39.951: DHCP: Lease Seconds: 129600    Renewal secs:  64800    Rebind secs:   1                                                                          13400
*Mar  1 00:17:39.951: DHCP: Server ID Option: 20.10.10.1
*Mar  1 00:17:40.163: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, change                                                                          d state to up
*Mar  1 00:17:42.987: DHCP: Releasing ipl options:
*Mar  1 00:17:42.987: DHCP: Applying DHCP options:
*Mar  1 00:17:42.991:   Setting default_gateway to 20.10.10.1
*Mar  1 00:17:42.991:   Adding default route 20.10.10.1

*Mar  1 00:17:43.995:   Setting default domain to dhcp.com.pk
*Mar  1 00:17:43.995: DHCP Client Pooling: ***Allocated IP address: 20.10.10.5
*Mar  1 00:17:44.071: Allocated IP address = 20.10.10.5  255.255.255.128

*Mar  1 00:17:44.075: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address        20.10.10.5, mask 255.255.255.128, hostname batman-router

 
This lab is same as previous Lab " HSRP Redundancy in Multi-homed ISPs - BGP AS-Path prepending" in many aspects but there were some short commings left in previous labs. Previously if our immediate route failed between our HSRP divice and ISP; we can track that but what if; Any of the link between source and destination fail. Previous configuration let our HSRP device working as Active device and we will face severe packet losses and communication errors. Here in this lab we will track ip addresses instead of connected interfaces so that if that route become unavailable then Active HSRP shift its role to standby ISP.

Let's do our lab.
Picture
Requiremnents:
  • Configure IP Addresses as per diagram. Configure one loop back address 5.5.5.5 on Internet router.
  • Configure HSRP on both HSRP1 (Active) and HSRP2 (standby). Track ip address between HSRP1 & internet for fail-over.
  • Configure IBGP in a way that HSRP1 should not sent BGP update to its neighbor HSRP2 and vice versa
  • Without doing any configuration related to propagating any network to neighbors, redistribution, static routing. Make sure network 100.10.10.0 should communicate to network 5.5.5.5.
  • Packet coming from internet router to LAN should take preffered path and ensure that secondary path route becomes less preferred as compared to preferred path
  • For verification use following command and compare results with previous Lab " HSRP Redundancy in Multi-homed ISPs - BGP AS-Path prepending" results. Follow these commands and take help from previous lab
  • Show ip route ; Show ip bgp ip-address ; traceroute or tracert ; ping ; show standby (for HSRP) ; show standby brief ; show ip bgp summary ; show ip bgp ; debug ip bgp etc

! HSRP1 Configuration
interface Serial0/0
ip address 16.16.16.1 255.255.255.0
no shut

interface FastEthernet0/1
ip address 100.10.10.1 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 150
standby 10 preempt delay minimum 70

standby 10 track 1 decrement 60




track 1 ip route 5.5.5.0 255.255.255.0 reachability



router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 16.16.16.2 remote-as 80
neighbor 100.10.10.2 remote-as 50
neighbor 100.10.10.2 next-hop-self
neighbor 100.10.10.2 transport connection-mode passive



! HSRP2 Configuration
interface FastEthernet0/0
ip address 100.10.10.2 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 120
standby 10 preempt
standby 10 track Serial0/0

interface Serial0/0
ip address 22.22.22.1 255.255.255.0
no shut

router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 22.22.22.2 remote-as 200
neighbor 22.22.22.2 route-map AS-Path-Append out

neighbor 100.10.10.1 remote-as 50
neighbor 100.10.10.1 next-hop-self
neighbor 100.10.10.1 transport connection-mode passive

access-list 10 permit 100.10.10.0


route-map AS-Path-Append permit 10
match ip address 10
set as-path prepend 50




! ISP1 Configuration
interface Serial0/0
ip address 16.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 160.16.16.1 255.255.255.0
no shut

router bgp 80
neighbor 16.16.16.1 remote-as 50
neighbor 160.16.16.2 remote-as 500

! ISP2 Configuration
interface Serial0/0
ip address 22.22.22.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.2 255.255.255.0
no shut

router bgp 200
neighbor 22.22.22.1 remote-as 50
neighbor 210.16.16.1 remote-as 500

! Internet Configuration
interface Loopback0
ip address 5.5.5.5 255.255.255.0

interface Serial0/0
ip address 160.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.1 255.255.255.0
no shut

router bgp 500
network 5.5.5.0 mask 255.255.255.0
neighbor 160.16.16.1 remote-as 80
neighbor 210.16.16.2 remote-as 200
Configuration Explanation










70 seconds delay so that BGP routes get into routing table.
Tracking track 1 (mentioned in next command). If 5.5.5.0 route fail to come into route table of HSRP1 ; HSRP1 shift role to standby router (HSRP router) by decrementing its current priority from 150 to 90

track to check if 5.5.5.0 is reachable









This command let HSRP2 not sending updates to its specified neighbor






















when communicating to neighbor 22.22.22.2 and sending information out to it; BGP should consult route-map name AS-PAth-Append

This command let HSRP2 not sending updates to its specified neighbor


Access list 10 permitting route. (We use this in route map)

Here comes route map
route map will match all ip addresses in access list 10
if match found then it will prepend its AS-Path attribute with 50. This will let outside world (AS) perceive that this route is the longest one as compared some other actually equal route.
 
In this lab, we are going to use IBGP and EBGP for peer relationship. HSRP will provide us redundant gateways as if active fail; standby will take the place of active HSRP. Read requirements carefully.
Picture
Requiremnents:
  • Configure IP Addresses as per diagram. Configure one loop back address 5.5.5.5 on Internet router.
  • Configure HSRP on both HSRP1 (Active) and HSRP2 (standby). Track interface between HSRP1 & ISP1 and HSRP2 & ISP2 for fail-over.
  • Without doing any configuration related to propagating any network to neighbors, redistribution, static routing. Make sure network 100.10.10.0 should communicate to network 5.5.5.5.
  • Packet coming from internet router to LAN should take preffered path and ensure that secondary path route becomes less preferred as compared to preferred path
  • Demonstrate internet router path for 100.10.10.0 network by using show ip bgp 100.10.10.0 command and by traceroute.

! HSRP1 Configuration
interface Serial0/0
ip address 16.16.16.1 255.255.255.0
no shut

interface FastEthernet0/1
ip address 100.10.10.1 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 150
standby 10 preempt delay minimum 70

standby 10 track Serial0/0 60

router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 16.16.16.2 remote-as 80
neighbor 100.10.10.2 remote-as 50
neighbor 100.10.10.2 next-hop-self

! HSRP2 Configuration
interface FastEthernet0/0
ip address 100.10.10.2 255.255.255.0
no shut

standby 10 ip 100.10.10.100
standby 10 priority 120
standby 10 preempt
standby 10 track Serial0/0

interface Serial0/0
ip address 22.22.22.1 255.255.255.0
no shut

router bgp 50
network 100.10.10.0 mask 255.255.255.0
neighbor 22.22.22.2 remote-as 200
neighbor 22.22.22.2 route-map AS-Path-Append out

neighbor 100.10.10.1 remote-as 50
neighbor 100.10.10.1 next-hop-self

access-list 10 permit 100.10.10.0


route-map AS-Path-Append permit 10
match ip address 10
set as-path prepend 50




! ISP1 Configuration
interface Serial0/0
ip address 16.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 160.16.16.1 255.255.255.0
no shut

router bgp 80
neighbor 16.16.16.1 remote-as 50
neighbor 160.16.16.2 remote-as 500

! ISP2 Configuration
interface Serial0/0
ip address 22.22.22.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.2 255.255.255.0
no shut

router bgp 200
neighbor 22.22.22.1 remote-as 50
neighbor 210.16.16.1 remote-as 500

! Internet Configuration
interface Loopback0
ip address 5.5.5.5 255.255.255.0

interface Serial0/0
ip address 160.16.16.2 255.255.255.0
no shut

interface Serial0/1
ip address 210.16.16.1 255.255.255.0
no shut

router bgp 500
network 5.5.5.0 mask 255.255.255.0
neighbor 160.16.16.1 remote-as 80
neighbor 210.16.16.2 remote-as 200
Configuration Explanation










70 seconds delay so that BGP routes get into routing table.
Tracking serial 0/0 so that if it gets failed; HSRP shift role to standby router























when communicating to neighbor 22.22.22.2 and sending information out to it; BGP should consult route-map name AS-PAth-Append



Access list 10 permitting route. (We use this in route map)

Here comes route map
route map will match all ip addresses in access list 10
if match found then it will prepend its AS-Path attribute with 50. This will let outside world (AS) perceive that this route is the longest one as compared some other actually equal route.

BGP network verification

Internet#show ip bgp 100.10.10.0
BGP routing table entry for 100.10.10.0/24, version 3
Paths: (2 available, best #2, table Default-IP-Routing-Table)
Flag: 0x820
  Advertised to update-groups:
        1
  200 50 50 [Look here you see that actual AS-Path should have (200 50) but due to route map and AS-Path prepend applied on HSRP2 router; Router AS path is showing that this route will go from 3 AS]
    210.16.16.2 from 210.16.16.2 (210.16.16.2)
      Origin IGP, localpref 100, valid, external
  80 50 [Here there are 2 AS in AS-Path; hence preferable]
    160.16.16.1 from 160.16.16.1 (160.16.16.1)
      Origin IGP, localpref 100, valid, external, best

Trace route verification

When both HSRP routers are running cool and tracked interfaces have no issues at all. Following is the trace route.

pc1V10[1]> tracert 5.5.5.5
traceroute to 5.5.5.5, 64 hops max, press Ctrl+C to stop
 1   100.10.10.1   70.000 ms  62.000 ms  40.000 ms
 2   16.16.16.2   80.000 ms  40.000 ms  36.000 ms
 3   *160.16.16.2   107.000 ms

(Please note that as 5.5.5.5 is a loopback thats why
traceroute just stops here)

Anyhow see the path. PAckets are taking HSRP1 path.

Now I have shutdown HSRP and ISP1 interface so that HSRP2 should take Active role. Now see results

Internet#show ip bgp 100.10.10.0
BGP routing table entry for 100.10.10.0/24, version 4
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Flag: 0x820
  Advertised to update-groups:
        1
  200 50 50
    210.16.16.2 from 210.16.16.2 (210.16.16.2)
      Origin IGP, localpref 100, valid, external, best

Please note that now previously preferred route is not there
pc1V10[1]> tracert 5.5.5.5
traceroute to 5.5.5.5, 64 hops max, press Ctrl+C to stop
 1   100.10.10.2   60.000 ms  30.000 ms  30.000 ms
 2   22.22.22.2   60.000 ms  40.000 ms  40.000 ms
 3   *210.16.16.1   72.000 ms

(Please note that as 5.5.5.5 is a loopback thats why
traceroute just stops here)

Anyhow see the path. PAckets are taking HSRP2 path.

 
Multihomed Border Gateway Protocol (BGP) network where you have connections to more then one separate Internet service providers (ISPs). In the event of a failure of connectivity toward one ISP, the traffic is rerouted dynamically through the other ISP with the Hot Standby Router Protocol (HSRP).
Picture
Requirements:
  • Configure IP Addresses on physical and vlan interfaces as per diagram
  • Configure HSRP on MLS1 and MLS2 so that MLS1 become HSRP Active and MLS2 will act as standby. MLS2 should take Active role if MLS one gets down or Interface between MLS1 and ISP goes down..
  • Configure EBGP neighbor relationship as required
  • Redistribute connected interfaces via BGP. MLS1 and MLS2 should not redistribute their connected interface
  • Send routing information of 100.10.10.0 network to all network routers via BGP.
  • Find result by pinging all interfaces and by finding traceroute of all interfaces

! MLS1HSRP1active Configuration
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.252
no shut

interface Vlan1
ip address 100.10.10.1 255.255.255.0
standby 10 ip 100.10.10.100
standby 10 priority 90
standby 10 preempt
standby 10 track FastEthernet0/0

router bgp 65222
network 100.10.10.0 mask 255.255.255.0
neighbor 1.1.1.2 remote-as 10

! ISP Configuration
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.252
no shut

interface Serial0/0
ip address 11.1.1.1 255.255.255.252
no shut

router bgp 10
redistribute connected
neighbor 1.1.1.1 remote-as 65222
neighbor 11.1.1.2 remote-as 20

! R8 Configuration
interface Serial0/0
ip address 11.1.1.2 255.255.255.252
no shut

interface Serial0/1
ip address 150.1.1.1 255.255.255.252
no shut

router bgp 20
redistribute connected
neighbor 11.1.1.1 remote-as 10
neighbor 150.1.1.2 remote-as 333

! R10 Configuration
interface Serial0/0
ip address 150.1.1.2 255.255.255.252
no shut

interface Serial0/1
ip address 170.1.1.1 255.255.255.252
no shut

interface Serial0/2
ip address 12.1.1.1 255.255.255.252
no shut

router bgp 333
redistribute connected
neighbor 12.1.1.2 remote-as 440
neighbor 150.1.1.1 remote-as 20
neighbor 170.1.1.2 remote-as 200
! MLS2HSRP2standby Configuration
interface FastEthernet0/0
ip address 2.2.2.1 255.255.255.252
no shut

interface Vlan1
ip address 100.10.10.2 255.255.255.0
standby 10 ip 100.10.10.100
standby 10 priority 50
standby 10 preempt
standby 10 track FastEthernet0/0

router bgp 65222
network 100.10.10.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 100

! ISP2 Configuration
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
no shut

interface Serial0/0
ip address 22.1.1.1 255.255.255.252
no shut

router bgp 100
redistribute connected
neighbor 2.2.2.1 remote-as 65222
neighbor 22.1.1.2 remote-as 200

! R9 Configuration
interface Serial0/0
ip address 22.1.1.2 255.255.255.252
no shut

interface Serial0/1
ip address 170.1.1.2 255.255.255.252
no shut

router bgp 200
redistribute connected
neighbor 22.1.1.1 remote-as 100
neighbor 170.1.1.1 remote-as 333

! Internet Configuration
interface Loopback0
ip address 44.44.44.44 255.255.255.255

interface Serial0/0
ip address 12.1.1.2 255.255.255.252
no shut

router bgp 440
redistribute connected
neighbor 12.1.1.1 remote-as 333

HSRP Basic lab1

6/22/2013

 
Picture
Requirement:
  • Configure IP address as per topology
  • Configure standby IP / VIP as per topology
  • Verify by debugging and see results
  • Configuring priority and preempt option
  • verify results again
  • Try to ping from PC to gateway. Take down active router interfaces by shutting it down. See if standyby router behave working as active and ping gets successful. Repeat same for standy router and see if listening router change its status from listening -> standby -> Active
  • Verification Command
    show standby
    show standby brief
    debug standby
    debug standby event
    debug standby packet

! Active Configuration
hostname Active

interface FastEthernet0/0
 ip address 1.1.1.50 255.255.255.0
 no shutdown

 standby 1 ip 1.1.1.100
 standby 1 priority 200

 standby 1 preempt

! standby Configuration
hostname standby

interface FastEthernet0/0
 ip address 1.1.1.55 255.255.255.0
 no shutdown

 standby 1 ip 1.1.1.100
 standby 1 preempt

! Listening Configuration
hostname Listening

interface FastEthernet0/0
 ip address 1.1.1.52 255.255.255.0
no shutdown

 standby 1 ip 1.1.1.100
 standby 1 priority 50
 standby 1 preempt

!PC1 Configuration
interface FastEthernet0/0
 ip address 1.1.1.1 255.255.255.0
no shutdown
Configuration Explanation
Changing host name to Active


Enabling interface with ip address


HSRP VIP address. We use it as a gateway
HSRP priority 200; Help us to decide between Active; Standby and Listening

BGP Confederation

6/17/2013

 
BGP confederation is used to reduce iBGP mesh within an AS. We can use many smaller private Autonomous systems with in one confederation ID. Routers with in each private AS are configured with full ibgo mesh. Each private AS with in confederation will communicate to other private AS in same confederation via EBGP. Other Confederations and Autonomous systems will see and communicate via Confederation ID.
REQUIREMENT:
Configure IP addresses as given in topology
Configure loopback 0 on R1 (11.11.11.11/32) and R4 (44.44.44.44/32)
Configure static routes on R9. Routes are 99.99.99.0/30 ; 99.99.99.4/30 ; 99.99.99.8/30 ; 99.99.99.12/30
Configure IBGP and EBGP as per topology
Configure IGP as if required
Configure Confederations as per topology
Redistribute all static routes of R9 to BGP

Verification
Verify neighbor relationships
Verify routes and find if all networks are reachable from everyone
Verify bgp tables


Router 1 Configuration
R1#config terminal

R1(config)#interface serial 0/0

R1(config-if)#ip address 1.1.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#clock rate 64000

 

R1(config)#interface loopback 0

R1(config-if)#ip address 11.11.11.11 255.255.255.255

 

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#no auto-summary

R1(config-router)#network 1.1.1.0

 

R1(config)#router bgp 1

R1(config-router)#network 11.11.11.11 mask 255.255.255.255

R1(config-router)#neighbor 1.1.1.2 remote-as 2

 

 Router 2 Configuration

 R2#conf t

R2(config)#interface serial 0/0

R2(config-if)#no shutdown

R2(config-if)#ip address 50.1.1.1 255.255.255.0


R2(config)#interface serial 0/1

R2(config-if)#no shutdown

R2(config-if)#ip address 10.1.1.2 255.255.255.0


R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 10.1.1.0

R2(config-router)#network 50.1.1.0


R2(config)#router bgp 65502

R2(config-router)#neighbor 10.1.1.1 remote-as 65502

R2(config-router)#neighbor 50.1.1.2 remote-as 65504

R2(config-router)#bgp confederation identifier 2




R2(config-router)#bgp confederation peers 65504




Router 3 Configuration
R3#conf t

R3(config)#interface serial 0/0

R3(config-if)#no shutdown

R3(config-if)#ip address 50.1.1.2 255.255.255.0

 

R3(config)#interface serial 0/1

R3(config-if)#no shutdown

R3(config-if)#ip address 100.1.1.1 255.255.255.0

 

R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#no auto-summary

R3(config-router)#network 50.1.1.0

R3(config-router)#network 100.1.1.0

 

R3(config)#router bgp 65504

R3(config-router)#neighbor 50.1.1.1 remote-as 65502

R3(config-router)#neighbor 100.1.1.2 remote-as 65504

R3(config-router)#bgp confederation identifier 2





R3(config-router)#bgp confederation peers 65502

 

Router 4 Configuration
R4#conf t

R4(config)#interface serial 0/0

R4(config-if)#no shutdown

R4(config-if)#ip address 100.1.1.2 255.255.255.0

 

R4(config)#int serial 0/1

R4(config-if)#no shutdown

R4(config-if)#ip address 2.2.2.1 255.255.255.0

 

R4(config)#int loopback 0

R4(config-if)#ip add 44.44.44.44 255.255.255.255

 

R4(config)#router rip

R4(config-router)#no auto-summary

R4(config-router)#version 2

R4(config-router)#network 100.1.1.0

R4(config-router)#network 2.2.2.0

 

R4(config)#router bgp 65504

R4(config-router)#neighbor 100.1.1.1 remote-as 65504

R4(config-router)#neighbor 2.2.2.2 remote-as 20

R4(config-router)#network 44.44.44.44 255.255.255.255

R4(config-router)#bgp confederation identifier 2




R4(config-router)#bgp confederation peers 65502

 

Router 5 Configuration
R5#configure terminal

R5(config)#int serial 0/0

R5(config-if)#no shutdown

R5(config-if)#ip address 10.1.1.1 255.255.255.0

 

R5(config)#int serial 0/1

R5(config-if)#ip address 1.1.1.2 255.255.255.0

R5(config-if)#no shutdown

 

R5(config)#router rip

R5(config-router)#no auto-summary

R5(config-router)#version 2

R5(config-router)#network 1.1.1.0

R5(config-router)#network 10.1.1.0

 

R5(config)#router bgp 65502

R5(config-router)#neighbor 1.1.1.1 remote-as 1

R5(config-router)#neighbor 10.1.1.2 remote-as 65502

R5(config-router)#bgp confederation identifier 2




R5(config-router)#bgp confederation peers 65504

 



Router 6 Configuration
 

 

R6#conf t

R6(config)#interface serial 0/0

R6(config-if)#ip address 2.2.2.2 255.255.255.0

 

R6(config)#interface serial 0/1

R6(config-if)#no shutdown

R6(config-if)#ip address 100.100.100.1 255.255.255.0

 

R6(config)#router rip

R6(config-router)#no auto-summary

R6(config-router)#version 2

R6(config-router)#network 2.2.2.0

R6(config-router)#network 100.100.100.0

 

R6(config)#router bgp 65504

R6(config-router)#neighbor 2.2.2.1 remote-as 2

R6(config-router)#neighbor 100.100.100.2 remote-as 65505

R6(config-router)#bgp confederation identifier 20




R6(config-router)#bgp confederation peers 65505


 



Router 7 Configuration
R7#conf t

R7(config)#interface serial 0/0

R7(config-if)#no shutdown

R7(config-if)#ip address 100.100.100.2 255.255.255.0

 

R7(config)#interface serial 0/1

R7(config-if)#no shutdown

R7(config-if)#ip address 10.10.10.1 255.255.255.0

 

R7(config)#router rip

R7(config-router)#no auto-summary

R7(config-router)#version 2

R7(config-router)#network 100.100.100.0

R7(config-router)#network 10.10.10.0

 

R7(config)#router bgp 65505

R7(config-router)#neighbor 10.10.10.2 remote-as 65502

R7(config-router)#neighbor 100.100.100.1 remote-as 65504

R7(config-router)#bgp confederation identifier 20




R7(config-router)#bgp confederation peers 65502 65504






Router 8 Configuration
R8#conf t

R8(config)#interface serial 0/0

R8(config-if)#no shutdown

R8(config-if)#ip address 10.10.10.2 255.255.255.0

 

R8(config)#interface serial 0/1

R8(config-if)#no shutdown

R8(config-if)#ip address 1.1.2.1 255.255.255.0

 

R8(config)#router rip

R8(config-router)#no auto-summary

R8(config-router)#version 2

R8(config-router)#network  10.10.10.0

R8(config-router)#network  1.1.2.0

 

R8(config)#router bgp 65502

R8(config-router)#neighbor 10.10.10.1 remote-as 65505

R8(config-router)#neighbor 1.1.2.2 remote-as 30

R8(config-router)#bgp confederation identifier 20




R8(config-router)#bgp confederation peers 65505

 




Router 9 Configuration
R9#conf t

R9(config)#interface serial 0/0

R9(config-if)#no shutdown

R9(config-if)#ip address 1.1.2.2 255.255.255.0

 

R9(config)#ip route 99.99.99.0 255.255.255.252 null 0

R9(config)#ip route 99.99.99.4 255.255.255.252 null 0

R9(config)#ip route 99.99.99.8 255.255.255.252 null 0

R9(config)#ip route 99.99.99.12 255.255.255.252 null 0

 

R9(config)#router rip

R9(config-router)#no auto-summary

R9(config-router)#version 2

R9(config-router)#network 1.1.2.0

 

R9(config)#router bgp 30

R9(config-router)#neighbor 1.1.2.1 remote-as 20

R9(config-router)#redistribute static


Configuration Explanation


Providing IP addresses to serial 0/0 interface









Providing IP addresses to Loopback0 interface





We are introducing RIP protocol as IGP.

version 2 for classless routing or discontegeous network support
Propagate subnets rather summary address






Configuring BGP AS 1

Propagating 11.11.11.11 via BGP


Making neighbor relationship with 1.1.1.2 of R5 in confederation 2

Configuration Explanation



Providing IP address to S 0/0






Providing IP address to S 0/1






Running RIP as IGP (Interior gateway protocol)










Running BGP with private AS 65502

Making neighbor relationship with 10.1.1.1

Making neighbor relationship with 50.1.1.2

This command is used to tell BGP that this private AS (65502) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65502) has peer relationship with another private AS (65504) of same confederation 2



Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 50.1.1.1

Making neighbor relationship with 100.1.1.2

This command is used to tell BGP that this private AS (65504) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65504) has peer relationship with another private AS (65502) of same confederation 2



Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Providing ip address to loopback 0





Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 100.1.1.1

Making neighbor relationship with 2.2.2.2




This command is used to tell BGP that this private AS (65504) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65504) has peer relationship with another private AS (65502) of same confederation 2

Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65502

Making neighbor relationship with 1.1.1.1

Making neighbor relationship with 10.1.1.2

This command is used to tell BGP that this private AS (65504) is a member of confederation 2. confederation AS 2 will be used to communicate outer world.

This command is telling router that our private AS (65502) has peer relationship with another private AS (65504) of same confederation 2



Configuration Explanation






Providing IP address to S 0/0





Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 2.2.2.1

Making neighbor relationship with 100.100.100.2

This command is used to tell BGP that this private AS (65504) is a member of confederation 20. confederation AS 20 will be used to communicate outer world.

This command is telling router that our private AS (65504) has peer relationship with another private AS (65505) of same confederation 2




Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65504

Making neighbor relationship with 10.10.10.2


Making neighbor relationship with 100.100.100.1

This command is used to tell BGP that this private AS (65505) is a member of confederation 20. confederation AS 20 will be used to communicate outer world.

This command is telling router that our private AS (65505) has peer relationship with two other private AS (65502 and 65504) of same confederation 2




Configuration Explanation


Providing IP address to S 0/0







Providing IP address to S 0/1







Running RIP as IGP (Interior gateway protocol)











Running BGP with private AS 65502

Making neighbor relationship with 10.10.10.1


Making neighbor relationship with 1.1.2.2

This command is used to tell BGP that this private AS (65502) is a member of confederation 20. confederation AS 20 will be used to communicate outer world.

This command is telling router that our private AS (65502) has peer relationship with another private AS (65505) of same confederation 20




Configuration Explanation


Providing IP address to S 0/0







Static IP routes null 0 interface









Running RIP as IGP (Interior gateway protocol)









Running BGP with AS 30

Making neighbor relationship with 1.1.2.1

Redistributing static routes
Now we will examine routing table of routers by show ip route command. I will only check R1 and R9 as if they are having good all routes then things will likely be OK in between but you should check during learning process all routers routing table
I am ending this lab over here. You can also try two commands

Show ip bgp summary
Debug ip bgp