Picture
Requirement:
  1. Configure IP Addresses on interfaces
  2. Configure R1 loopback 10.1.1.1 ; R2 loopback 20.1.1.1 ; R3 loopback 30.1.1.1
  3. Configure static route on R1 and redistribute it to bgp
  4. Configure IBGP AS 20 on all routers
  5. Make neighbor relationship
  6. BGP split horizon will not allow R2 to propagate one neighbor's route to other.





Look into routing tables and neighbor tables of bgp. Try to find interesting results.

Verification commands:
Show ip route
Show ip bgp summary
Show ip bgp
Debug ip bgp                   => Always use this command to verify and learn

Router 1 Configuration

R1(config)#interface Loopback0
R1(config-if)# ip address 10.1.1.1 255.255.255.0

R1(config-if)#interface Serial0/0
R1(config-if)# ip address 1.1.1.1 255.255.255.252
R1(config-if)# clock rate 64000
R1(config-if)#no shutdown

R1(config-if)#ip route 12.12.12.12 255.255.255.255 Null0

R1(config)#router bgp 20
R1(config-router)# network 1.1.1.0 mask 255.255.255.252
R1(config-router)# network 10.1.1.0 mask 255.255.255.0
R1(config-router)# redistribute static
R1(config-router)# neighbor 1.1.1.2 remote-as 20

Router 2 Configuration
R2#conf t
R2(config)#interface Loopback0
R2(config-if)# ip address 20.1.1.1 255.255.255.0

R2(config-if)#interface Serial0/0
R2(config-if)# ip address 1.1.1.2 255.255.255.252
R2(config-if)# clock rate 2000000
R2(config-if)#no shutdown

R2(config-if)#interface Serial0/1
R2(config-if)# ip address 2.2.2.1 255.255.255.252
R2(config-if)# clock rate 64000
R2(config-if)#no shutdown

R2(config)#router bgp 20
R2(config-router)# network 1.1.1.0 mask 255.255.255.252
R2(config-router)# network 2.2.2.0 mask 255.255.255.252
R2(config-router)# network 20.1.1.0 mask 255.255.255.0
R2(config-router)# neighbor 1.1.1.1 remote-as 20
R2(config-router)# neighbor 2.2.2.2 remote-as 20


Router 3 Configuration
R3(config)#interface Loopback0
R3(config-if)# ip address 30.1.1.1 255.255.255.0

R3(config-if)#interface Serial0/0
R3(config-if)# ip address 2.2.2.2 255.255.255.252
R3(config-if)#no shut

R3(config-if)#router bgp 20
R3(config-router)# network 2.2.2.0 mask 255.255.255.252
R3(config-router)# network 30.1.1.0 mask 255.255.255.0
R3(config-router)# neighbor 2.2.2.1 remote-as 20

Configuration Explanation

Configuring loop back interface


Configuring serial 0/0 interface




Static route to Null 0 interface


Configuring BGP for Autonomous system 20
Propagating network 1.1.1.0

Propagating network 10.1.1.0

Redistributing static routes to BGP
Making neighbor relationship with 1.1.1.2 of R2



Configuring loop back interface


Configuring serial 0/0 interface




Configuring serial 0/1 interface




Configuring BGP for Autonomous system 20
Propagating network 1.1.1.0

Propagating network 2.2.2.0

Propagating network 20.1.1.0

Making neighbor relationship with 1.1.1.1 of R1
Making neighbor relationship with 2.2.2.2 of R3



Configuring Loopback 0 interface


Configuring serial 0/0 interface



Configuring BGP 20
Propagating network 2.2.2.0

Propagating network 30.1.1.0

Making neighbor relationship with 2.2.2.1 of R2
Picture
Verification Command

R1# Show ip route
R2# Show ip route
R3# Show ip route










R2 has all routes from R1 and R3 but due to split horizon rule; R2 is not sending R1's route to R3 and R3 routes to R1


Let's see neighbor table of all three routers
Picture
Command

R1# Show ip bgp summary
R2# Show ip bgp summary
R3# Show ip bgp summary

Let's see all possible routes of BGP. Look at following snapshot
Picture
This output is showing Router ID.
* means all valid routes
> means best route between all possible routes to a network

 
Picture
Requirement:
  1. Configure IP addresses as given
  2. Configure discontigeous networks on router 1 and router 3 loopback 0.
  3. Run Rip version 2 on all routers
  4. Check if both Discontigeous networks are reachable from router 6. We will ping both networks and you will see results.

Router 1 configuration

R1(config)#interface Loopback0
R1(config-if)# ip address 200.100.100.1 255.255.255.128

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 1.1.1.1 255.255.255.252
R1(config-if)# no shutdown

R1(config)#router rip
 R1(config-router)#version 2
R1(config-router)#no auto-summary
 R1(config-router)#network 1.0.0.0
 R1(config-router)#network 200.100.100.0


Router 2 configuration

R2(config)# interface FastEthernet0/0
 R2(config-if)#ip address 1.1.1.2 255.255.255.252
  R2(config-if)# no shutdown

R2(config)# interface FastEthernet0/1
  R2(config-if)#ip address 2.2.2.1 255.255.255.252
  R2(config-if)#no shutdown

R2(config)# interface FastEthernet1/0
  R2(config-if)#ip address 3.3.3.1 255.255.255.252
  R2(config-if)#speed 100
  R2(config-if)#duplex full
R2(config-if)#no shutdown

R2(config)# router rip
  R2(config-router)#version 2
R2(config-router)#no auto-summary
 R2(config-router)#network 1.0.0.0
 R2(config-router)#network 2.0.0.0
 R2(config-router)#network 3.0.0.0


R1# show ip protocols
Router 3 configuration

R3(config)#interface Loopback0
R1(config-if)# ip address 200.100.100.150 255.255.255.128

R3(config)#interface FastEthernet0/0
R3(config-if)# ip address 2.2.2.2 255.255.255.252
R3(config-if)#no shutdown

R3(config)#router rip
 R3(config-router)#version 2
R3(config-router)#no auto-summary
 R3(config-router)#network 2.0.0.0
 R3(config-router)#network 200.100.100.0


Router 6 configuration

R6(config)#interface FastEthernet0/0
 R6(config-if)#ip address 3.3.3.2 255.255.255.252
R6(config-if)# speed 100
R6(config-if)# full-duplex
R6(config-if)#no shutdown

R6(config)# ip route 0.0.0.0 0.0.0.0 3.3.3.1
R2# Show ip route
Here we ping from Router 6 to R1 and R3 loopback interfaces ip addresses ( which are discontigeous). Let see results. From undermentioned ping images, we have found that ping to 200.100.100.150 and  200.100.100.1 is successful.
Compare both Trace routes. You will find that 2nd Hop of both routes are different
Compare both Trace routes. You will find that 2nd Hop of both routes are different
 
Picture
Requirement:
  1. Configure IP addresses as given
  2. Configure discontigeous networks on router 1 and router 3 loopback 0.
  3. Run Rip version 1 on all routers
  4. Check if both Discontigeous networks are reachable from router 6. We will ping both networks and you will see results.

Router 1 configuration

R1(config)#interface Loopback0
R1(config-if)# ip address 200.100.100.1 255.255.255.128

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 1.1.1.1 255.255.255.252
R1(config-if)# no shutdown

R1(config)#router rip
 R1(config-router)#version 1
 R1(config-router)#network 1.0.0.0
 R1(config-router)#network 200.100.100.0


Router 2 configuration

R2(config)# interface FastEthernet0/0
 R2(config-if)#ip address 1.1.1.2 255.255.255.252
  R2(config-if)# no shutdown

R2(config)# interface FastEthernet0/1
  R2(config-if)#ip address 2.2.2.1 255.255.255.252
  R2(config-if)#no shutdown

R2(config)# interface FastEthernet1/0
  R2(config-if)#ip address 3.3.3.1 255.255.255.252
  R2(config-if)#speed 100
  R2(config-if)#duplex full
R2(config-if)#no shutdown

R2(config)# router rip
  R2(config-router)#version 1
 R2(config-router)#network 1.0.0.0
 R2(config-router)#network 2.0.0.0
 R2(config-router)#network 3.0.0.0


R1# show ip protocols
Router 3 configuration

R3(config)#interface Loopback0
R1(config-if)# ip address 200.100.100.150 255.255.255.128

R3(config)#interface FastEthernet0/0
R3(config-if)# ip address 2.2.2.2 255.255.255.252
R3(config-if)#no shutdown

R3(config)#router rip
 R3(config-router)#version 1
 R3(config-router)#network 2.0.0.0
 R3(config-router)#network 200.100.100.0


Router 6 configuration

R6(config)#interface FastEthernet0/0
 R6(config-if)#ip address 3.3.3.2 255.255.255.252
R6(config-if)# speed 100
R6(config-if)# full-duplex
R6(config-if)#no shutdown

R6(config)# ip route 0.0.0.0 0.0.0.0 3.3.3.1

R2# Show ip route
Here we ping from Router 6 to R1 and R3 loopback interfaces ip addresses ( which are discontigeous). Let see results. From undermentioned ping images, we have found that ping to 200.100.100.150 is successful but ping to 200.100.100.1 is unsuccessful.
Picture
Here we have tried to find reason for different result of ping.

Ahaa !! Reason found.
In both cases, Router 2 is forwarding packets to 2.2.2.2 which is at fastethernet 0/1 by following routing table first entry and hence reach 200.100.100.150 but fail to reach 200.100.100.1.

Show controllers

6/16/2013

 
Picture

1. Show controllers
This command will show full hardware level controller information of all attached interfaces.

2. Show controllers serial 0/0
This command will show full hardware level controller information for interface serial 0/0 only
.
3. Show controllers fastethernet 0/0
This command will show full hardware level controller information for interface fastethernet 0/0 only

 
Picture














R2#show version

CCNA Basic Lab 1

6/15/2013

 
Picture
 Requirement
  1. Change hostname of R1 to USA-Router
  2. Configure password on console
  3. Configure login name and password on console
  4. Configure enable password
  5. Configure enable secret
  6. Configure ip addresses on both routers interfaces
  7. Configure password for Telnet
  8. Configure login name and password for telnet

R1 configuration
R1>enable           

R1#            
       
R1# configure terminal    

R1(config)# 
       
R1(config)# hostname USA-Router

USA-Router(config)#
USA-Router(config)#Line console 0
USA-Router(config-line)#password cisco
USA-Router(config-line)#login


USA-Router#exit
USA-Router#configure terminal
USA-Router(config)#username irfan password mypass
USA-Router(config)#line console 0
USA-Router(config-line)#login local






USA-Router#exit

USA-Router(config)#enable password mypassword



USA-Router(config)#enable secret mysecret




USA-Router(config)#interface fastethernet 0/0
USA-Router(config-if)#ip address 1.1.1.1 255.255.255.252
USA-Router(config-if)#no shutdown



USA-Router(config)#line vty ?
  <0-1340>  First Line number


USA-Router(config)#line vty 0 4


USA-Router(config-line)#password vtypass
USA-Router(config-line)#login local
USA-Router(config-line)#no login local

USA-Router(config-line)#login



Router 2 configuration
R2#configuration terminal
R2(config)#int fastEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#ip address 1.1.1.2 255.255.255.252
R2(config-if)# Ctrl+c or exit
R2#telnet 1.1.1.1
Command Help
(This command Let you enter privileged or enable mode)
( > signifies user mode and # signifies that you are in enable mode)
(This command Let you enter in configuration mode; You can only do configuration in this mode)
(config)# signifies that you are in global configuration mode
hostname command let you change host name from R1 to USA-Router
Please notice that hose name has changed
Entering into console line
Putting password on console line
login command let router ask for password when you try to enter via console. Let's check by exiting our of our router and try to re-enter.
Exiting from router

After giving exit command, and couple of enters. You will be prompted for password. This is a console password we just set.

Please note that for security reasons your typed password will not show anything on screen; so don't get confused while working.


Enter into configuration mode
Set username and password for into router

This command let you get into line console 0
Please look into it and try to recall; Last time when we have just given password to console; Our command was just "login" but now we have written "login local". Login local let router know that now from onward it will ask for username as well as password (User based authentication).

Let exit from router and try to find out if there is any difference.


Have you noticed any difference. Look under

1) Router is asking for user as well as password
2) When you have given user and password, it has just thrown you into user mode rather enable mode (look into previous image).



Setting password to enter into enable mode.
Try to exit from router and check; This time it will not let you in enable mode without password.

Secret is an encrypted password. If you have set both password and secret. Secret will take precedence. However; you will find both in your router configuration file.

Enter into interface f0/0 for ip addressing
ip address has been given with mask

By default, Router interface are shutdown so if you want them workable then give this command.


? is a great help, when you need to find any command or its portion put question mark. Here it shows how many line vty (telnet) line we have

This command will let us in vty line 0 to 4. means now what so we do, it will get applied on only line 0 to 4.
Set password on vty lines 0 to 4
login local tell router to ask for user and password
if we put "no" before any command that command will get deleted or non-effective.
login let router ask for only password we set.



Router 2 configuration starts
Enter into configuration terminal
entering into interface f0/0
opening shutdown interface
giving ip address to interface
exiting from interface mode to enable mode
Let's telnet our router 1's interface fastethernet 0/0 ip address 1.1.1.1.

Telnet result shows that router 1 is asking for password due to "login" command on vty lines. if we configure "login local" command, router will ask for user and password.

When we have given vty lines password. Look we have enter into USA-Router. Now we can configure or look into USA-Router configuration as per privileges
.
Check to verify


 
Picture
Controller commands:

1. show controllers
2. show controllers serial 0/0
3. show controllers fastethernet 0/0









R2#show controllers                                      This command show full hardware level detailed information of all interfaces controllers

R2#show controllers serial 0/0                      This will only show specific hardware controller information related to  serial 0/0
R2#show controllers fastethernet 0/0            This will only show specific hardware controller information related to  f 0/0

Please find both commands outpt

EBGP Lab no 1

6/12/2013

 
Picture
In this Lab, We are configuring all three routers in three different autonomous systems and making them EBGP neighbor.









Basic Configuration of Topology

R1 (Router 1)
interface Loopback0
ip address 10.1.1.1 255.255.255.0

interface Serial0/0
ip address 1.1.1.1 255.255.255.252
clock rate 64000
no sh

router bgp 1
network 1.1.1.0 mask 255.255.255.252
network 10.1.1.0 mask 255.255.255.0
neighbor 1.1.1.2 remote-as 2

Router: 2


interface Loopback0
ip address 20.1.1.1 255.255.255.0

interface Serial0/0
ip address 1.1.1.2 255.255.255.252
clock rate 64000
no sh

interface Serial0/1
ip address 2.2.2.1 255.255.255.252
clock rate 64000
no sh

router bgp 2
network 1.1.1.0 mask 255.255.255.252
network 2.2.2.0 mask 255.255.255.252
network 20.1.1.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 1
neighbor 2.2.2.2 remote-as 3

Router-3
interface Loopback0
ip address 30.1.1.1 255.255.255.0

interface Serial0/0
ip address 2.2.2.2 255.255.255.252
clock rate 64000
no sh

router bgp 3
network 2.2.2.0 mask 255.255.255.252
network 30.1.1.0 mask 255.255.255.0
neighbor 2.2.2.1 remote-as 2

Verification Commands:
For routing table: Show ip route
For BGP neighbour relationship: show ip bgp summary
For BGP full routing information: Show ip bgp