CCNA Basic Lab 1

6/15/2013

 
Picture
 Requirement
  1. Change hostname of R1 to USA-Router
  2. Configure password on console
  3. Configure login name and password on console
  4. Configure enable password
  5. Configure enable secret
  6. Configure ip addresses on both routers interfaces
  7. Configure password for Telnet
  8. Configure login name and password for telnet

R1 configuration
R1>enable           

R1#            
       
R1# configure terminal    

R1(config)# 
       
R1(config)# hostname USA-Router

USA-Router(config)#
USA-Router(config)#Line console 0
USA-Router(config-line)#password cisco
USA-Router(config-line)#login


USA-Router#exit
USA-Router#configure terminal
USA-Router(config)#username irfan password mypass
USA-Router(config)#line console 0
USA-Router(config-line)#login local






USA-Router#exit

USA-Router(config)#enable password mypassword



USA-Router(config)#enable secret mysecret




USA-Router(config)#interface fastethernet 0/0
USA-Router(config-if)#ip address 1.1.1.1 255.255.255.252
USA-Router(config-if)#no shutdown



USA-Router(config)#line vty ?
  <0-1340>  First Line number


USA-Router(config)#line vty 0 4


USA-Router(config-line)#password vtypass
USA-Router(config-line)#login local
USA-Router(config-line)#no login local

USA-Router(config-line)#login



Router 2 configuration
R2#configuration terminal
R2(config)#int fastEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#ip address 1.1.1.2 255.255.255.252
R2(config-if)# Ctrl+c or exit
R2#telnet 1.1.1.1
Command Help
(This command Let you enter privileged or enable mode)
( > signifies user mode and # signifies that you are in enable mode)
(This command Let you enter in configuration mode; You can only do configuration in this mode)
(config)# signifies that you are in global configuration mode
hostname command let you change host name from R1 to USA-Router
Please notice that hose name has changed
Entering into console line
Putting password on console line
login command let router ask for password when you try to enter via console. Let's check by exiting our of our router and try to re-enter.
Exiting from router

After giving exit command, and couple of enters. You will be prompted for password. This is a console password we just set.

Please note that for security reasons your typed password will not show anything on screen; so don't get confused while working.


Enter into configuration mode
Set username and password for into router

This command let you get into line console 0
Please look into it and try to recall; Last time when we have just given password to console; Our command was just "login" but now we have written "login local". Login local let router know that now from onward it will ask for username as well as password (User based authentication).

Let exit from router and try to find out if there is any difference.


Have you noticed any difference. Look under

1) Router is asking for user as well as password
2) When you have given user and password, it has just thrown you into user mode rather enable mode (look into previous image).



Setting password to enter into enable mode.
Try to exit from router and check; This time it will not let you in enable mode without password.

Secret is an encrypted password. If you have set both password and secret. Secret will take precedence. However; you will find both in your router configuration file.

Enter into interface f0/0 for ip addressing
ip address has been given with mask

By default, Router interface are shutdown so if you want them workable then give this command.


? is a great help, when you need to find any command or its portion put question mark. Here it shows how many line vty (telnet) line we have

This command will let us in vty line 0 to 4. means now what so we do, it will get applied on only line 0 to 4.
Set password on vty lines 0 to 4
login local tell router to ask for user and password
if we put "no" before any command that command will get deleted or non-effective.
login let router ask for only password we set.



Router 2 configuration starts
Enter into configuration terminal
entering into interface f0/0
opening shutdown interface
giving ip address to interface
exiting from interface mode to enable mode
Let's telnet our router 1's interface fastethernet 0/0 ip address 1.1.1.1.

Telnet result shows that router 1 is asking for password due to "login" command on vty lines. if we configure "login local" command, router will ask for user and password.

When we have given vty lines password. Look we have enter into USA-Router. Now we can configure or look into USA-Router configuration as per privileges
.
Check to verify


 
Picture
Controller commands:

1. show controllers
2. show controllers serial 0/0
3. show controllers fastethernet 0/0









R2#show controllers                                      This command show full hardware level detailed information of all interfaces controllers

R2#show controllers serial 0/0                      This will only show specific hardware controller information related to  serial 0/0
R2#show controllers fastethernet 0/0            This will only show specific hardware controller information related to  f 0/0

Please find both commands outpt

EBGP Lab no 1

6/12/2013

 
Picture
In this Lab, We are configuring all three routers in three different autonomous systems and making them EBGP neighbor.









Basic Configuration of Topology

R1 (Router 1)
interface Loopback0
ip address 10.1.1.1 255.255.255.0

interface Serial0/0
ip address 1.1.1.1 255.255.255.252
clock rate 64000
no sh

router bgp 1
network 1.1.1.0 mask 255.255.255.252
network 10.1.1.0 mask 255.255.255.0
neighbor 1.1.1.2 remote-as 2

Router: 2


interface Loopback0
ip address 20.1.1.1 255.255.255.0

interface Serial0/0
ip address 1.1.1.2 255.255.255.252
clock rate 64000
no sh

interface Serial0/1
ip address 2.2.2.1 255.255.255.252
clock rate 64000
no sh

router bgp 2
network 1.1.1.0 mask 255.255.255.252
network 2.2.2.0 mask 255.255.255.252
network 20.1.1.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 1
neighbor 2.2.2.2 remote-as 3

Router-3
interface Loopback0
ip address 30.1.1.1 255.255.255.0

interface Serial0/0
ip address 2.2.2.2 255.255.255.252
clock rate 64000
no sh

router bgp 3
network 2.2.2.0 mask 255.255.255.252
network 30.1.1.0 mask 255.255.255.0
neighbor 2.2.2.1 remote-as 2

Verification Commands:
For routing table: Show ip route
For BGP neighbour relationship: show ip bgp summary
For BGP full routing information: Show ip bgp



 
Picture
Requirement:
  • show mac address of interface
  • change mac address of interface
  • Configure link local ipv6 addresses on interfaces
  • ping and check connectivity

! ipv61 configuration

hostname ipv61
interface FastEthernet0/0
 mac-address bcde.9988.22aa
 no shutdown
 ipv6 enable

! ipv62 configuration

hostname ipv62
interface FastEthernet0/0
mac-address dcaa.4433.0066
 no shutdown
 ipv6 enable

Verification:

ipv61#show interface fastEthernet 0/0 ;
FastEthernet0/0 is administratively down, line protocol is down
  Hardware is Gt96k FE, address is c400.1ad4.0000 (bia c400.1ad4.0000)

Note: Compare both addresses mentioned above. Both are same. We have checked this before giving mac-address command to router

After giving mac-address bcde.9988.22aa command to router

------------------------------------------------------------------------------------------------------------------------------------------------

ipv61(config-if)#mac-address bcde.9988.22aa

ipv61#sh int f0/0
FastEthernet0/0 is administratively down, line protocol is down
  Hardware is Gt96k FE, address is bcde.9988.22aa (bia c400.1ad4.0000)

Note: Compare both addresses mentioned above. Both are now different

------------------------------------------------------------------------------------------------------------------------------------------------
ipv61# debug ipv6 packet
IPv6 unicast packet debugging is on

ipv61(config-if)#ipv6 enable

*Mar  1 01:16:45.395: IPv6-IDB: FastEthernet0/0 is up, IPv6 is (up, enabled): enabling
*Mar  1 01:16:45.411: IPV6: source :: (local)
*Mar  1 01:16:45.411:       dest FF02::1:FF88:22AA (FastEthernet0/0)
*Mar  1 01:16:45.411:       traffic class 224, flow 0x0, len 64+16, prot 58, hops 255, originating
*Mar  1 01:16:45.411: IPv6: Sending on FastEthernet0/0
*Mar  1 01:16:45.427: IPV6: source :: (local)
*Mar  1 01:16:45.427:       dest FF02::16 (FastEthernet0/0)
*Mar  1 01:16:45.427:       traffic class 224, flow 0x0, len 76+0, prot 0, hops 1, originating
*Mar  1 01:16:45.427: IPv6: Sending on FastEthernet0/0
*Mar  1 01:16:46.191: IPV6: source :: (local)
ipv61(config-if)#
*Mar  1 01:16:46.191:       dest FF02::16 (FastEthernet0/0)
*Mar  1 01:16:46.191:       traffic class 224, flow 0x0, len 76+0, prot 0, hops 1, originating
*Mar  1 01:16:46.195: IPv6: Sending on FastEthernet0/0
*Mar  1 01:16:46.411: IPV6: source FE80::BEDE:99FF:FE88:22AA (local)
*Mar  1 01:16:46.411:       dest FF02::1 (FastEthernet0/0)
*Mar  1 01:16:46.411:       traffic class 224, flow 0x0, len 72+8, prot 58, hops 255, originating
*Mar  1 01:16:46.415: IPv6: Sending on FastEthernet0/0
*Mar  1 01:16:46.415: IPV6: source FE80::BEDE:99FF:FE88:22AA (local)
*Mar  1 01:16:46.415:       dest FF02::16 (FastEthernet0/0)
ipv61(config-if)#
*Mar  1 01:16:46.419:       traffic class 224, flow 0x0, len 76+0, prot 0, hops 1, originating
*Mar  1 01:16:46.419: IPv6: Sending on FastEthernet0/0
*Mar  1 01:16:46.419: IPv6-IDB: FastEthernet0/0 is up, IPv6 is (up, enabled): came up
ipv61(config-if)#
*Mar  1 01:16:47.423: IPV6: source FE80::BEDE:99FF:FE88:22AA (local)
*Mar  1 01:16:47.423:       dest FF02::16 (FastEthernet0/0)
*Mar  1 01:16:47.423:       traffic class 224, flow 0x0, len 76+0, prot 0, hops 1, originating
*Mar  1 01:16:47.427: IPv6: Sending on FastEthernet0/0

------------------------------------------------------------------------------------------------------------------------------------------------
ipv61#show ipv6 interface brief
FastEthernet0/0            [up/up]
    FE80::BEDE:99FF:FE88:22AA
FastEthernet0/1            [administratively down/down]




ipv62#ping ipv6 FE80::BEDE:99FF:FE88:22AA

Output Interface: fastethernet0/0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::BEDE:99FF:FE88:22AA, timeout is 2 seconds:
Packet sent with a source address of FE80::DEAA:44FF:FE33:66
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/57/176 ms